summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-02-10 21:46:25 +0000
committerDaniel Bermond2021-02-10 21:46:25 +0000
commit566c18290b650373d98b11270eeabd7f48e149cf (patch)
tree0ac171e84a921d196607ab1f9a869b3a8b7e16e1
parent111b052c0766959a47bac8c217f4c9c9cb193049 (diff)
downloadaur-566c18290b650373d98b11270eeabd7f48e149cf.tar.gz
Remove unneeded prepare(). Updates dependencies. Cosmetic changes.
Code on prepare() is not needed anymore, since upstream now properly provides tags. Also on this commit: - dropped i686 support - added check()
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD53
2 files changed, 19 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb5cc87573fa..a45c7caa8e2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = egl-wayland-git
pkgdesc = EGLStream-based Wayland external platform (git version)
- pkgver = 1.1.0.r1.g0eb29d4
- pkgrel = 2
+ pkgver = 1.1.6.r0.g1b0f2b8
+ pkgrel = 1
url = https://github.com/NVIDIA/egl-wayland/
- arch = i686
arch = x86_64
license = MIT
makedepends = git
makedepends = meson
+ makedepends = eglexternalplatform
+ makedepends = libegl
depends = wayland
- depends = eglexternalplatform
provides = egl-wayland
conflicts = egl-wayland
source = git+https://github.com/NVIDIA/egl-wayland.git
diff --git a/PKGBUILD b/PKGBUILD
index 1b845364a7b8..3ba178db9713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Det
pkgname=egl-wayland-git
-_srcname=egl-wayland
-pkgver=1.1.0.r1.g0eb29d4
-pkgrel=2
+pkgver=1.1.6.r0.g1b0f2b8
+pkgrel=1
pkgdesc='EGLStream-based Wayland external platform (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/NVIDIA/egl-wayland/'
license=('MIT')
-depends=('wayland' 'eglexternalplatform')
-makedepends=('git' 'meson')
+depends=('wayland')
+makedepends=('git' 'meson' 'eglexternalplatform' 'libegl')
provides=('egl-wayland')
conflicts=('egl-wayland')
source=('git+https://github.com/NVIDIA/egl-wayland.git'
@@ -18,44 +17,22 @@ source=('git+https://github.com/NVIDIA/egl-wayland.git'
sha256sums=('SKIP'
'5cccf1905a266e8e34d5ad4aad4be85390e60b1a0850a29dd9d64adc641de412')
-prepare() {
- cd "$_srcname"
-
- # add missing upstream tag
- # https://github.com/NVIDIA/egl-wayland/commit/1676d1d2bfe646fb3ecbba29a85db529dd399493
- local _tag
- _tag="$(git tag -l 1.1.0)"
- [ "$_tag" != '1.1.0' ] && git tag 1.1.0 1676d1d2bfe646fb3ecbba29a85db529dd399493
-}
-
pkgver() {
- cd "$_srcname"
-
- # git, tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C egl-wayland describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$_srcname"
-
- arch-meson . build
-
+ arch-meson build egl-wayland
ninja -C build
}
+check() {
+ ninja -C build test
+}
+
package() {
- cd "$_srcname"
-
- DESTDIR="$pkgdir" meson install -C build
-
- # headers
- install -d -m755 "${pkgdir}/usr/include"
- install -m755 include/*.h "${pkgdir}/usr/include"
-
- # license
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # egl loader
- cd "$srcdir"
+ DESTDIR="$pkgdir" ninja install -C build
+ install -D -m644 egl-wayland/include/*.h -t "${pkgdir}/usr/include"
install -D -m644 10_nvidia_wayland.json -t "${pkgdir}/usr/share/egl/egl_external_platform.d"
+ install -D -m644 egl-wayland/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}