summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-09-11 10:12:00 -0300
committerDaniel Bermond2021-09-11 10:12:00 -0300
commitb1eb20788e14fa65f4a2b359a5e2b9a4a0b92a21 (patch)
tree52cb2bcb9f668e986202845e074e8b455f9022c2
parent566c18290b650373d98b11270eeabd7f48e149cf (diff)
downloadaur-b1eb20788e14fa65f4a2b359a5e2b9a4a0b92a21.tar.gz
Update dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a45c7caa8e2d..714205432ec4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = egl-wayland-git
pkgdesc = EGLStream-based Wayland external platform (git version)
- pkgver = 1.1.6.r0.g1b0f2b8
+ pkgver = 1.1.8.r0.gce4c963
pkgrel = 1
url = https://github.com/NVIDIA/egl-wayland/
arch = x86_64
@@ -8,9 +8,11 @@ pkgbase = egl-wayland-git
makedepends = git
makedepends = meson
makedepends = eglexternalplatform
- makedepends = libegl
+ makedepends = libglvnd>=1.3.4
+ makedepends = wayland-protocols
depends = wayland
provides = egl-wayland
+ provides = libnvidia-egl-wayland.so
conflicts = egl-wayland
source = git+https://github.com/NVIDIA/egl-wayland.git
source = 10_nvidia_wayland.json
@@ -18,4 +20,3 @@ pkgbase = egl-wayland-git
sha256sums = 5cccf1905a266e8e34d5ad4aad4be85390e60b1a0850a29dd9d64adc641de412
pkgname = egl-wayland-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ba178db9713..5cec650ad1ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Det
pkgname=egl-wayland-git
-pkgver=1.1.6.r0.g1b0f2b8
+pkgver=1.1.8.r0.gce4c963
pkgrel=1
pkgdesc='EGLStream-based Wayland external platform (git version)'
arch=('x86_64')
url='https://github.com/NVIDIA/egl-wayland/'
license=('MIT')
depends=('wayland')
-makedepends=('git' 'meson' 'eglexternalplatform' 'libegl')
-provides=('egl-wayland')
+makedepends=('git' 'meson' 'eglexternalplatform' 'libglvnd>=1.3.4' 'wayland-protocols')
+provides=('egl-wayland' 'libnvidia-egl-wayland.so')
conflicts=('egl-wayland')
source=('git+https://github.com/NVIDIA/egl-wayland.git'
'10_nvidia_wayland.json')
@@ -32,7 +32,7 @@ check() {
package() {
DESTDIR="$pkgdir" ninja install -C build
- install -D -m644 egl-wayland/include/*.h -t "${pkgdir}/usr/include"
+ cp -dr --no-preserve='ownership' egl-wayland/include "${pkgdir}/usr"
install -D -m644 10_nvidia_wayland.json -t "${pkgdir}/usr/share/egl/egl_external_platform.d"
install -D -m644 egl-wayland/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}