summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael2022-09-17 23:42:47 +0200
committerMichael2022-09-17 23:42:47 +0200
commit4cc5b193801a001962fdd61b193abf8915a1c178 (patch)
tree6a2001f36f0bffa681429c38561d0630fef2a75c
downloadaur-4cc5b193801a001962fdd61b193abf8915a1c178.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--egpu-switcher-bin.install15
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72ef82f18a65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = egpu-switcher-bin
+ pkgdesc = Automatically detect and use eGPU on startup
+ pkgver = 0.18.0.rc.1
+ pkgrel = 1
+ url = https://github.com/hertg/egpu-switcher
+ install = egpu-switcher-bin.install
+ arch = x86_64
+ license = GPL
+ provides = egpu-switcher
+ conflicts = egpu-switcher
+ source = egpu-switcher-bin-0.18.0.rc.1::https://github.com/hertg/egpu-switcher/releases/download/0.18.0-rc.1/egpu-switcher-amd64
+ sha256sums = 9733e406e2f391be5e3e7941c24877910575d2738cdcae65368e36a43beabc80
+
+pkgname = egpu-switcher-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f3eb9056618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: hertg <aur@her.tg>
+# This file is generated automatically
+_version=0.18.0-rc.1
+_pkgname=egpu-switcher-bin
+_pkgver=0.18.0.rc.1
+_sha256sum=9733e406e2f391be5e3e7941c24877910575d2738cdcae65368e36a43beabc80
+_source=${_pkgname}-${_pkgver}::https://github.com/hertg/egpu-switcher/releases/download/0.18.0-rc.1/egpu-switcher-amd64
+pkgname=$_pkgname
+pkgver=$_pkgver
+pkgdesc='Automatically detect and use eGPU on startup'
+pkgrel=1
+arch=(x86_64)
+license=('GPL')
+url='https://github.com/hertg/egpu-switcher'
+provides=(egpu-switcher)
+conflicts=(egpu-switcher)
+install=${pkgname}.install
+source=($_source)
+sha256sums=($_sha256sum)
+
+package() {
+ install -Dm755 "${pkgname}-${pkgver}" "$pkgdir/usr/bin/egpu-switcher"
+}
diff --git a/egpu-switcher-bin.install b/egpu-switcher-bin.install
new file mode 100644
index 000000000000..2cb293c24134
--- /dev/null
+++ b/egpu-switcher-bin.install
@@ -0,0 +1,15 @@
+pre_remove() {
+ egpu-switcher disable
+}
+
+post_install() {
+ egpu-switcher enable --no-prompt
+}
+
+pre_upgrade() {
+ egpu-switcher cleanup
+}
+
+post_upgrade() {
+ egpu-switcher enable --no-prompt
+}