summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNelson Santos2020-10-12 14:04:50 -0400
committerNelson Santos2020-10-12 14:04:50 -0400
commita4f6855ab79ff237244b8d5f14acbda9d0948a6f (patch)
tree2932bd4ce648ef26782ae81f66a202c318d8057a
downloadaur-a4f6855ab79ff237244b8d5f14acbda9d0948a6f.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--egpu-switcher-git.install3
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..461ab3eeb822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = egpu-switcher-git
+ pkgdesc = Distribution agnostic script that works with NVIDIA and AMD cards.
+ pkgver = 0.16.0.r0.gd22ce2e
+ pkgrel = 1
+ url = https://github.com/hertg/egpu-switcher
+ install = egpu-switcher-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = pciutils>=3.3.0
+ depends = bash>=4.0
+ provides = egpu-switcher
+ conflicts = egpu-switcher
+ source = egpu-switcher-git::git+https://github.com/hertg/egpu-switcher.git
+ md5sums = SKIP
+
+pkgname = egpu-switcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7c78ef02190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nelson Santos <nbsantos@gmail.com>
+_pkgname=egpu-switcher
+pkgname=$_pkgname-git
+pkgver=0.16.0.r0.gd22ce2e
+pkgrel=1
+pkgdesc="Distribution agnostic script that works with NVIDIA and AMD cards."
+arch=('any')
+url="https://github.com/hertg/egpu-switcher"
+license=('GPL')
+depends=('pciutils>=3.3.0' 'bash>=4.0')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+install=${pkgname}.install
+source=("${pkgname}::git+https://github.com/hertg/egpu-switcher.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+}
+
diff --git a/egpu-switcher-git.install b/egpu-switcher-git.install
new file mode 100644
index 000000000000..86575ca1bd96
--- /dev/null
+++ b/egpu-switcher-git.install
@@ -0,0 +1,3 @@
+pre_remove() {
+ egpu-switcher cleanup
+}