summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2020-12-06 09:10:12 +0100
committerKrzysztof AS (3ED)2020-12-06 09:10:12 +0100
commit4fecff964d4d7dc823d45c9e2bcf14ce38541534 (patch)
tree300a1e1f7fa1affa01d39adc72b976613effd682
parent95a1a72a701a5e3c75c3459724ab5a188c8d0cd5 (diff)
downloadaur-4fecff964d4d7dc823d45c9e2bcf14ce38541534.tar.gz
update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
-rw-r--r--rename_attr-xattr_to_sys-xattr.patch41
3 files changed, 14 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fde18ddb0167..c5d9cf8d38b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = eiciel
pkgdesc = GNOME file ACL editor
- pkgver = 0.9.12.1
- pkgrel = 3
+ pkgver = 0.9.13
+ pkgrel = 1
url = http://rofi.roger-ferrer.org/eiciel/
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
depends = acl
depends = gtkmm3
depends = nautilus
depends = desktop-file-utils
options = !libtool
- source = http://rofi.roger-ferrer.org/eiciel/files/eiciel-0.9.12.1.tar.bz2
- source = rename_attr-xattr_to_sys-xattr.patch
- source = gnome-3.36_avoid_cpp_nautilus-extension.patch::https://src.fedoraproject.org/rpms/eiciel/raw/39db553efacba0ed9272a533b829b3ba8d8ac315/f/eiciel-0.9.12.1-nautilus-exports.patch
- sha512sums = f54fbb149eed7f8fd534b77ec5e2d0f579c68a39afd7417a2298d75c7e95c459b49fc8ccb66d0188956ffaadf3bcc8a3eb048425cb82fc875573eb131f4b0494
- sha512sums = db612691b1fae68b476d1d244d6bd3e54a770994a50c7f3644c87da9dfe6b0ae4fc1d5a9b0f02b8ea4d3d8a7e8ff46178fe605e9ff283eeeed50d1c21cf84b53
- sha512sums = b391287588a9383fa051926a2597bff97bea70015efe2b427d51286a8087a4e4ed8afd677484799bb77eaaaf02cabb97742a8a8f2b539c0819d47e8424c0f845
+ source = eiciel::git+https://github.com/rofirrim/eiciel.git#tag=0.9.13
+ sha512sums = SKIP
pkgname = eiciel
diff --git a/PKGBUILD b/PKGBUILD
index 88cae5d3c737..e50ec31aba02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,46 +3,31 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=eiciel
-pkgver=0.9.12.1
-pkgrel=3
+pkgver=0.9.13
+pkgrel=1
pkgdesc="GNOME file ACL editor"
arch=('i686' 'x86_64')
url="http://rofi.roger-ferrer.org/eiciel/"
license=('GPL')
depends=('acl' 'gtkmm3' 'nautilus' 'desktop-file-utils')
+makedepends=('git')
options=('!libtool')
-source=(
- http://rofi.roger-ferrer.org/eiciel/files/${pkgname}-${pkgver}.tar.bz2
- rename_attr-xattr_to_sys-xattr.patch
- gnome-3.36_avoid_cpp_nautilus-extension.patch::https://src.fedoraproject.org/rpms/eiciel/raw/39db553efacba0ed9272a533b829b3ba8d8ac315/f/eiciel-0.9.12.1-nautilus-exports.patch
-)
-sha512sums=('f54fbb149eed7f8fd534b77ec5e2d0f579c68a39afd7417a2298d75c7e95c459b49fc8ccb66d0188956ffaadf3bcc8a3eb048425cb82fc875573eb131f4b0494'
- 'db612691b1fae68b476d1d244d6bd3e54a770994a50c7f3644c87da9dfe6b0ae4fc1d5a9b0f02b8ea4d3d8a7e8ff46178fe605e9ff283eeeed50d1c21cf84b53'
- 'b391287588a9383fa051926a2597bff97bea70015efe2b427d51286a8087a4e4ed8afd677484799bb77eaaaf02cabb97742a8a8f2b539c0819d47e8424c0f845')
+source=(${pkgname}::git+https://github.com/rofirrim/${pkgname}.git#tag=${pkgver})
+sha512sums=('SKIP')
prepare() {
- msg2 "Applying: rename attr/xattr -> sys/xattr"
- patch -p1 < rename_attr-xattr_to_sys-xattr.patch
-
- msg2 "Applying: gnome-3.36 - avoid C++ nautilus-extension (instead use extern C)"
- patch -p0 < gnome-3.36_avoid_cpp_nautilus-extension.patch
-
- cd "${srcdir}/${pkgname}-${pkgver}"
- msg2 "Applying fast fix for: aclocal>1.15"
- aclocal
- msg2 "Applying fast fix for: automake>1.15"
- automake
+ cd "${srcdir}/${pkgname}"
+ autoreconf -vif
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-# CXXFLAGS="-std=c++11"
+ cd "${srcdir}/${pkgname}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
make DESTDIR="${pkgdir}" install
}
diff --git a/rename_attr-xattr_to_sys-xattr.patch b/rename_attr-xattr_to_sys-xattr.patch
deleted file mode 100644
index 703ef8a182ee..000000000000
--- a/rename_attr-xattr_to_sys-xattr.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- src/eiciel-0.9.12.1/configure.ac 2018-01-16 19:41:43.000000000 +0000
-+++ src2/eiciel-0.9.12.1/configure.ac 2018-09-28 09:20:06.548646722 +0000
-@@ -156,7 +156,7 @@
-
- if test x$enable_eua = xyes;
- then
-- AC_CHECK_HEADERS([attr/xattr.h], [], AC_MSG_ERROR([This header is mandatory for extended user attributes support]), [])
-+ AC_CHECK_HEADERS([sys/xattr.h], [], AC_MSG_ERROR([This header is mandatory for extended user attributes support]), [])
- AC_DEFINE([ENABLE_USER_XATTR], [1], [Enables user extended attributes support])
- fi
- AM_CONDITIONAL(ENABLE_USER_XATTR, test x$enable_eua = xyes)
-
---- src/eiciel-0.9.12.1/configure 2018-01-16 19:41:51.000000000 +0000
-+++ src2/eiciel-0.9.12.1/configure 2018-09-28 09:00:29.392747415 +0000
-@@ -19169,9 +19169,9 @@
- if test x$enable_eua = xyes;
- then
-
--for ac_header in attr/xattr.h
-+for ac_header in sys/xattr.h
- do :
-- ac_fn_cxx_check_header_mongrel "$LINENO" "attr/xattr.h" "ac_cv_header_attr_xattr_h" "$ac_includes_default"
-+ ac_fn_cxx_check_header_mongrel "$LINENO" "sys/xattr.h" "ac_cv_header_attr_xattr_h" "$ac_includes_default"
- if test "x$ac_cv_header_attr_xattr_h" = xyes; then :
- cat >>confdefs.h <<_ACEOF
- #define HAVE_ATTR_XATTR_H 1
-
---- src/eiciel-0.9.12.1/src/xattr_manager.hpp 2014-08-20 08:06:00.000000000 +0000
-+++ src2/eiciel-0.9.12.1/src/xattr_manager.hpp 2018-09-28 09:12:54.336485500 +0000
-@@ -26,7 +26,10 @@
- #include <sys/stat.h>
- #include <unistd.h>
-
--#include <attr/xattr.h>
-+#include <sys/xattr.h>
-+#ifndef ENOATTR
-+#define ENOATTR ENODATA
-+#endif
-
- #include <string>
- #include <cstring>