summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2017-01-08 19:28:39 +0100
committerWilliam Gathoye2017-01-08 19:28:39 +0100
commit944df0c598ec4db6e63d89a8af5b6420167cb8ae (patch)
treef4b8e17d9d1ec49763c74dffa5cb34cf75c43324
parent0bf08faef383c53c7ecc78450ebce7ba8c79622a (diff)
downloadaur-944df0c598ec4db6e63d89a8af5b6420167cb8ae.tar.gz
Update to 4.1.21 and use sha512
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
2 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bdbb848090f..33891f2f28da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eid-mw
- pkgdesc = The eID middleware for the Belgian eID
- pkgver = 4.1.18
+ pkgdesc = eID Middleware is the middleware for the Belgian electronic identity card
+ pkgver = 4.1.21
pkgrel = 1
url = http://eid.belgium.be/
arch = i686
@@ -12,10 +12,11 @@ pkgbase = eid-mw
optdepends = acsccid: ACS CCID smart card readers
optdepends = ccid: A generic USB Chip/Smart Card Interface Devices driver
optdepends = pcsc-tools: PC/SC smartcard tools
- source = https://dist.eid.belgium.be/continuous/sources/eid-mw-4.1.18-v4.1.18.tar.gz
- source = https://dist.eid.belgium.be/continuous/sources/eid-mw-4.1.18-v4.1.18.tar.gz.asc
- md5sums = d27be9ac6f63e864c539c50b3db76763
- md5sums = SKIP
+ source = https://dist.eid.belgium.be/continuous/sources/eid-mw-4.1.21-v4.1.21.tar.gz
+ source = https://dist.eid.belgium.be/continuous/sources/eid-mw-4.1.21-v4.1.21.tar.gz.asc
+ validpgpkeys = D95426E309C0492990D8E8E2824A5E0010A04D46
+ sha512sums = adcf6678754d366492c66e91cfefe6b950ca5aa601c55bb146998a9265aec90b3832e1514cbf905a5b13a1e3d27a28338ba36e7cab4ef62e506f1ae5e9bab9da
+ sha512sums = 9dd1184f111a88f4ce7e7c48a95d677c6bf1c70b1d9f3ca7b909c89f881affe1f931685cc39aa543fd3efd750abadb67e6645c5236cfcd31beb825259f8bb85d
pkgname = eid-mw
diff --git a/PKGBUILD b/PKGBUILD
index f2992badbab9..99ca02dedfd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,37 @@
-# Maintainer: Emil Vanherp <emil DOT vanherp @ hot mail DOT com>
+# Maintainer: William Gathoye <william at gathoye dot be>
+# Contributor: Emil Vanherp <emil dot vanherp at hotmail dot com>
# Contributor: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
-# Contributor: Xavier D. <magicrhesus@ouranos.be>
-# Contributor: Valere Monseur <valere.monseur@ymail.com>
+# Contributor: Xavier D. <magicrhesus at ouranos dot be>
+# Contributor: Valere Monseur <valere dot monseur at ymail dot com>
pkgname=eid-mw
-pkgver=4.1.18
+pkgver=4.1.21
pkgrel=1
-pkgdesc="The eID middleware for the Belgian eID"
-url=http://eid.belgium.be/
+pkgdesc="eID Middleware is the middleware for the Belgian electronic identity card"
arch=('i686' 'x86_64')
+url=http://eid.belgium.be/
license=('LGPL3')
depends=('pcsclite' 'gtk2')
-optdepends=('firefox: extension for Belgian eid'
- 'acsccid: ACS CCID smart card readers'
- 'ccid: A generic USB Chip/Smart Card Interface Devices driver'
- 'pcsc-tools: PC/SC smartcard tools')
-source=("https://dist.eid.belgium.be/continuous/sources/$pkgname-$pkgver-v$pkgver.tar.gz"{,.asc})
-md5sums=('d27be9ac6f63e864c539c50b3db76763'
- 'SKIP')
-validpgpkeys=('D95426E309C0492990D8E8E2824A5E0010A04D46')
+optdepends=(
+ 'firefox: extension for Belgian eid'
+ 'acsccid: ACS CCID smart card readers'
+ 'ccid: A generic USB Chip/Smart Card Interface Devices driver'
+ 'pcsc-tools: PC/SC smartcard tools')
+
+source=(
+ "https://dist.eid.belgium.be/continuous/sources/$pkgname-$pkgver-v$pkgver.tar.gz"{,.asc}
+)
+sha512sums=(
+ adcf6678754d366492c66e91cfefe6b950ca5aa601c55bb146998a9265aec90b3832e1514cbf905a5b13a1e3d27a28338ba36e7cab4ef62e506f1ae5e9bab9da
+9dd1184f111a88f4ce7e7c48a95d677c6bf1c70b1d9f3ca7b909c89f881affe1f931685cc39aa543fd3efd750abadb67e6645c5236cfcd31beb825259f8bb85d
+)
+
+validpgpkeys=(
+ D95426E309C0492990D8E8E2824A5E0010A04D46 # Belgian eID Automatic Signing Key (continuous builds)
+)
+
build() {
cd "$pkgname-$pkgver-v$pkgver"
./configure --prefix=/usr --libexecdir=/usr/bin
@@ -31,5 +42,3 @@ package() {
cd "$pkgname-$pkgver-v$pkgver"
make install DESTDIR="$pkgdir"
}
-
-# vim:set ts=2 sw=2 et: