summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bazin2017-10-17 08:34:25 +0200
committerQuentin Bazin2017-10-17 08:34:25 +0200
commit6dfd3c501516972602a9e254a162d5a9fad27639 (patch)
treebc1b311c15d323970c4c0f61d03827d708442736
parent806433db096ce7a18f1508101048e48d9a9cc919 (diff)
downloadaur-6dfd3c501516972602a9e254a162d5a9fad27639.tar.gz
[PKGBUILD] Updated.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ea5d79cec97..6d702138e196 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = eifl-git
url = https://github.com/Quent42340/EIFL
arch = i686
arch = x86_64
- license = None
makedepends = cmake
makedepends = cpr-git
depends = qt5-base
diff --git a/PKGBUILD b/PKGBUILD
index 00c5b1715d93..def23b68e29b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,17 @@ pkgver=0.0.1
pkgrel=1
pkgdesc="Epitech Intra for Linux"
arch=("i686" "x86_64")
-license=("None")
url="https://github.com/Quent42340/EIFL"
depends=("qt5-base" "qtkeychain" "curl")
makedepends=("cmake" "cpr-git")
source=("${_pkgname}::git+${url}.git")
md5sums=("SKIP")
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "${_pkgname}"
cmake .