summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwuyudi2023-02-16 01:09:52 +0900
committerwuyudi2023-02-16 01:09:52 +0900
commit5d8a5c80a06040c86d8fb90047c9fea93781fbf6 (patch)
treed6dc05d21380bc601414d4a2609854ffeecd90f9
downloadaur-5d8a5c80a06040c86d8fb90047c9fea93781fbf6.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6d51c23d60b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eigenmath-git
+ pkgdesc = Symbolic math app
+ pkgver = r2380.4b00787
+ pkgrel = 1
+ url = https://github.com/georgeweigt/eigenmath
+ arch = any
+ license = BSD
+ makedepends = git
+ provides = eigenmath
+ source = git+https://github.com/georgeweigt/eigenmath.git
+ source = https://georgeweigt.github.io/eigenmath.pdf
+ md5sums = SKIP
+ md5sums = 564095e39c563a7b7e03a218e448b8bd
+
+pkgname = eigenmath-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1b2eecf8d07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: asukaminato <asukaminato@nyan.eu.org>
+pkgname=eigenmath-git
+pkgver=r2380.4b00787
+pkgrel=1
+pkgdesc="Symbolic math app"
+arch=('any')
+url="https://github.com/georgeweigt/eigenmath"
+license=('BSD')
+provides=('eigenmath')
+makedepends=('git')
+source=("git+https://github.com/georgeweigt/eigenmath.git"
+ "https://georgeweigt.github.io/eigenmath.pdf")
+md5sums=('SKIP'
+ '564095e39c563a7b7e03a218e448b8bd')
+pkgver(){
+ cd eigenmath
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build(){
+ cd eigenmath
+ make
+}
+check(){
+ cd eigenmath
+ printf "exit\n" >> test/selftest1
+ printf "exit\n" >> test/selftest2
+ ./eigenmath test/selftest1
+ ./eigenmath test/selftest2
+}
+package(){
+ pushd eigenmath
+ install -Dm755 eigenmath $pkgdir/usr/bin/eigenmath
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ for f in doc/*;
+ do
+ install -Dm644 $f -t $pkgdir/usr/share/doc/$pkgname/
+ done
+ popd
+ install -Dm644 eigenmath.pdf -t $pkgdir/usr/share/doc/$pkgname/
+}