summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAronYoung2023-08-04 10:28:55 +0800
committerAronYoung2023-08-04 10:28:55 +0800
commite76c29a53ddf74a0161e58d93e58af2c34411cb9 (patch)
treeccf66182e2973fb8e84f2cbfaf318e429cff8588
parentc9b55073416cdcd8ee44d21b48c8103ffbdf60f1 (diff)
downloadaur-e76c29a53ddf74a0161e58d93e58af2c34411cb9.tar.gz
fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD52
2 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f795c9aa65b2..c4fbb7cf355e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,6 @@ pkgbase = eigenmath-git
source = git+https://github.com/georgeweigt/eigenmath.git
source = https://georgeweigt.github.io/eigenmath.pdf
md5sums = SKIP
- md5sums = 5bd1ac29f2546e9677ea3adfc51b4aa2
+ md5sums = e7d02ede8cd5cb9f8a3143dd04be4d21
pkgname = eigenmath-git
diff --git a/PKGBUILD b/PKGBUILD
index b998b0a066dc..c6a58515d7c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,40 @@
+# Contributor: Asuka Minato
+pkgname=eigenmath-git
+pkgver=r2637.f202cf0
+pkgrel=1
pkgdesc="Symbolic math app"
arch=('any')
-# Contributor: Asuka Minato
url="https://github.com/georgeweigt/eigenmath"
license=('BSD')
provides=('eigenmath')
makedepends=('git')
source=("git+https://github.com/georgeweigt/eigenmath.git"
- "https://georgeweigt.github.io/eigenmath.pdf")
+ "https://georgeweigt.github.io/eigenmath.pdf")
md5sums=('SKIP'
- '5bd1ac29f2546e9677ea3adfc51b4aa2')
-pkgver(){
- cd eigenmath
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ 'e7d02ede8cd5cb9f8a3143dd04be4d21')
+pkgver() {
+ cd eigenmath
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
-build(){
- cd eigenmath
- make
+build() {
+ cd eigenmath
+ make
}
-check(){
- cd eigenmath
- printf "exit\n" >> test/selftest1
- printf "exit\n" >> test/selftest2
- ./eigenmath test/selftest1
- ./eigenmath test/selftest2
+check() {
+ cd eigenmath
+ printf "exit\n" >>test/selftest1
+ printf "exit\n" >>test/selftest2
+ ./eigenmath test/selftest1
+ ./eigenmath test/selftest2
}
-package(){
- pushd eigenmath
- install -Dm755 eigenmath -t "${pkgdir}/usr/bin/"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
- for f in doc/*;
- do
- install -Dm644 "${f}" -t "${pkgdir}/usr/share/doc/${pkgname}/"
- done
- popd
- install -Dm644 eigenmath.pdf -t "${pkgdir}/usr/share/doc/${pkgname}/"
+package() {
+ pushd eigenmath
+ install -Dm755 eigenmath -t "${pkgdir}/usr/bin/"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ for f in doc/*; do
+ install -Dm644 "${f}" -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ done
+ popd
+ install -Dm644 eigenmath.pdf -t "${pkgdir}/usr/share/doc/${pkgname}/"
}