summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2019-05-02 09:41:05 +0200
committerGuilhem Saurel2019-05-02 09:41:05 +0200
commit6f04ed018e32271206b2b79a09bbaccc37d78163 (patch)
treecc1005a1462d1e7c5af2f785e3e66b5799d31231
parent37d37325ffa24737f203abb21450bdab0bbad383 (diff)
downloadaur-6f04ed018e32271206b2b79a09bbaccc37d78163.tar.gz
install license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ede9aad2b1ee..47ade8bf9801 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = eigenpy
url = https://github.com/stack-of-tasks/eigenpy
arch = i686
arch = x86_64
- license = BSD 2-clause
+ license = BSD
makedepends = cmake
makedepends = eigen
makedepends = boost
diff --git a/PKGBUILD b/PKGBUILD
index d07d9b9a703b..185c75498fb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Bindings between numpy and eigen using boost::python"
arch=('i686' 'x86_64')
url="https://github.com/stack-of-tasks/$pkgname"
-license=('BSD 2-clause')
+license=('BSD')
depends=('boost-libs')
optdepends=('doxygen')
makedepends=('cmake' 'eigen' 'boost' 'python-numpy')
@@ -24,4 +24,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING.LESSER "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}