summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornemaeon2015-07-30 18:23:24 -0400
committernemaeon2015-07-30 18:23:24 -0400
commit72a1ed2d917ad45272271410220dd139a2bcad26 (patch)
treeec3e93c89c105aadb8cdde8a1905ebce50dde54e
downloadaur-72a1ed2d917ad45272271410220dd139a2bcad26.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--ChangeLog10
-rw-r--r--PKGBUILD58
-rw-r--r--arch.patch25
-rw-r--r--einstein.pngbin0 -> 23293 bytes
5 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..789e60262cae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = einstein
+ pkgdesc = Remake of old DOS game Sherlock which was inspired by Albert Einstein's puzzle
+ pkgver = 2.0
+ pkgrel = 5
+ url = http://web.archive.org/web/20120521062745/http://games.flowix.com/en/index.html
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = sharutils
+ makedepends = ttf-dejavu
+ depends = sdl_ttf
+ depends = sdl_mixer
+ depends = xorg-server
+ source = http://old-releases.ubuntu.com/ubuntu/pool/universe/e/einstein/einstein_2.0.dfsg.2.orig.tar.gz
+ source = http://old-releases.ubuntu.com/ubuntu/pool/universe/e/einstein/einstein_2.0.dfsg.2-5.diff.gz
+ source = einstein.png
+ source = arch.patch
+ md5sums = d47d4ae80478d4d8d5796e65d134124f
+ md5sums = 11291eeee59b2a999196e1dba2efaa65
+ md5sums = 81b58f2e3c61c0b50716992a30f2d4cc
+ md5sums = 68c261ccda52b9978ed030a240ef91ea
+
+pkgname = einstein
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..86d6d6801e30
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,10 @@
+2014-09-03 Mariusz Libera <mariusz.libera@gmail.com>
+
+ 2.0-4:
+ * added changelog
+ * moved ttf-dejavu from depends to makedepends
+ * changed x-server to xorg-server in depends array
+ * added prepare function
+ * removed uses of $startdir and "|| return 1"
+ * replaced mkdir with install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e99ffcea525a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: nemesys nemstar AT zoho DOT com
+# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
+# Contributor: Kevin Piche <kevin@archlinux.org>
+# Contributor: K. Piche <kpiche@rogers.com>
+# Contributor: Artiom Molchanov ar.molchanov gmail.com
+pkgname=einstein
+pkgver=2.0
+pkgrel=5
+pkgdesc="Remake of old DOS game Sherlock which was inspired by Albert Einstein's puzzle"
+url="http://web.archive.org/web/20120521062745/http://games.flowix.com/en/index.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('sdl_ttf' 'sdl_mixer' 'xorg-server')
+makedepends=('sharutils' 'ttf-dejavu')
+changelog=ChangeLog
+source=("http://old-releases.ubuntu.com/ubuntu/pool/universe/e/${pkgname}/${pkgname}_${pkgver}.dfsg.2.orig.tar.gz"
+ "http://old-releases.ubuntu.com/ubuntu/pool/universe/e/${pkgname}/${pkgname}_${pkgver}.dfsg.2-5.diff.gz"
+ "${pkgname}.png"
+ "arch.patch")
+md5sums=('d47d4ae80478d4d8d5796e65d134124f'
+ '11291eeee59b2a999196e1dba2efaa65'
+ '81b58f2e3c61c0b50716992a30f2d4cc'
+ '68c261ccda52b9978ed030a240ef91ea')
+
+prepare() {
+ patch -p0 < arch.patch
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < ../einstein_2.0.dfsg.2-5.diff
+ patch -p0 < debian/patches/01_sdl.diff
+ patch -p0 < debian/patches/02_prefix.diff
+ patch -p0 < debian/patches/03_fonts.diff
+ patch -p0 < debian/patches/04_fame.diff
+ patch -p0 < debian/patches/05_icon.diff
+ patch -p0 < debian/patches/06_srand.diff
+ patch -p0 < debian/patches/07_long.diff
+ patch -p0 < debian/patches/08_gcc43.diff
+ patch -p0 < debian/patches/09_colors.diff
+ patch -p0 < debian/patches/10_gcc43.diff
+
+ uudecode debian/einstein.png.uue
+ uudecode debian/icon.bmp.uue
+ [ -f res/DejaVuSans.ttf ] || cp -p /usr/share/fonts/TTF/DejaVuSans.ttf res/
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make PREFIX="${pkgdir}/usr" install
+
+ install -Dm 644 "debian/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
+
diff --git a/arch.patch b/arch.patch
new file mode 100644
index 000000000000..c40599ecf82e
--- /dev/null
+++ b/arch.patch
@@ -0,0 +1,25 @@
+--- einstein_2.0.dfsg.2-5.diff.orig 2013-01-26 17:23:38.297314526 +0100
++++ einstein_2.0.dfsg.2-5.diff 2013-01-26 17:28:17.374267298 +0100
+@@ -961,7 +961,7 @@
+
+ $(TARGET): $(OBJECTS)
+ + cd mkres && make
+-+ cd res && ../mkres/mkres --source resources.descr --output einstein.res
+++ cd res && ../mkres/mkres --source resources.descr --output ../einstein.res
+ $(CXX) $(LNFLAGS) $(OBJECTS) -o $(TARGET)
+
+ clean:
+@@ -971,13 +971,3 @@
+
+ depend:
+ @makedepend $(SOURCES) 2> /dev/null
+-@@ -61,8 +65,7 @@
+- ./$(TARGET)
+-
+- install: $(TARGET)
+-- $(INSTALL) -s -D $(TARGET) $(PREFIX)/bin/$(TARGET)
+-- $(INSTALL) -D einstein.res $(PREFIX)/share/einstein/res/einstein.res
+-+ $(INSTALL) -s -D $(TARGET) $(DESTDIR)/$(PREFIX)/games/$(TARGET)
+-
+- # DO NOT DELETE THIS LINE -- make depend depends on it.
+-
diff --git a/einstein.png b/einstein.png
new file mode 100644
index 000000000000..ad87a9acee11
--- /dev/null
+++ b/einstein.png
Binary files differ