summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornemesys2019-08-22 23:07:23 +0000
committernemesys2019-08-22 23:07:23 +0000
commit9d4e89cd0f005d514716a1798b5e59622c13069e (patch)
treea56e427cbe567a639e57f9db1bbeb6c091307413
parent72a1ed2d917ad45272271410220dd139a2bcad26 (diff)
downloadaur-9d4e89cd0f005d514716a1798b5e59622c13069e.tar.gz
Update to use master git branch of project.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD51
-rw-r--r--arch.patch25
-rw-r--r--einstein.desktop12
4 files changed, 34 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 789e60262cae..e2a5f4b29e96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,24 @@
pkgbase = einstein
pkgdesc = Remake of old DOS game Sherlock which was inspired by Albert Einstein's puzzle
pkgver = 2.0
- pkgrel = 5
- url = http://web.archive.org/web/20120521062745/http://games.flowix.com/en/index.html
+ pkgrel = 6
+ url = https://github.com/lksj/einstein-puzzle
changelog = ChangeLog
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
makedepends = sharutils
makedepends = ttf-dejavu
depends = sdl_ttf
depends = sdl_mixer
depends = xorg-server
- source = http://old-releases.ubuntu.com/ubuntu/pool/universe/e/einstein/einstein_2.0.dfsg.2.orig.tar.gz
- source = http://old-releases.ubuntu.com/ubuntu/pool/universe/e/einstein/einstein_2.0.dfsg.2-5.diff.gz
+ source = git+git://github.com/lksj/einstein-puzzle.git
+ source = einstein.desktop
source = einstein.png
- source = arch.patch
- md5sums = d47d4ae80478d4d8d5796e65d134124f
- md5sums = 11291eeee59b2a999196e1dba2efaa65
+ md5sums = SKIP
+ md5sums = 4da7f4b1b17f7385ef2cb14fc6326997
md5sums = 81b58f2e3c61c0b50716992a30f2d4cc
- md5sums = 68c261ccda52b9978ed030a240ef91ea
pkgname = einstein
diff --git a/PKGBUILD b/PKGBUILD
index e99ffcea525a..bcb8657784bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,37 @@
-# Maintainer: nemesys nemstar AT zoho DOT com
+# Maintainer: nemesys nemstar zoho.com
# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
# Contributor: Kevin Piche <kevin@archlinux.org>
# Contributor: K. Piche <kpiche@rogers.com>
# Contributor: Artiom Molchanov ar.molchanov gmail.com
pkgname=einstein
+_gitname=einstein-puzzle
pkgver=2.0
-pkgrel=5
+pkgrel=6
pkgdesc="Remake of old DOS game Sherlock which was inspired by Albert Einstein's puzzle"
-url="http://web.archive.org/web/20120521062745/http://games.flowix.com/en/index.html"
+#original="http://web.archive.org/web/20120521062745/http://games.flowix.com/en/index.html"
+url="https://github.com/lksj/einstein-puzzle"
arch=('i686' 'x86_64')
license=('GPL')
depends=('sdl_ttf' 'sdl_mixer' 'xorg-server')
-makedepends=('sharutils' 'ttf-dejavu')
+makedepends=('git' 'sharutils' 'ttf-dejavu')
changelog=ChangeLog
-source=("http://old-releases.ubuntu.com/ubuntu/pool/universe/e/${pkgname}/${pkgname}_${pkgver}.dfsg.2.orig.tar.gz"
- "http://old-releases.ubuntu.com/ubuntu/pool/universe/e/${pkgname}/${pkgname}_${pkgver}.dfsg.2-5.diff.gz"
- "${pkgname}.png"
- "arch.patch")
-md5sums=('d47d4ae80478d4d8d5796e65d134124f'
- '11291eeee59b2a999196e1dba2efaa65'
- '81b58f2e3c61c0b50716992a30f2d4cc'
- '68c261ccda52b9978ed030a240ef91ea')
-
-prepare() {
- patch -p0 < arch.patch
-
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../einstein_2.0.dfsg.2-5.diff
- patch -p0 < debian/patches/01_sdl.diff
- patch -p0 < debian/patches/02_prefix.diff
- patch -p0 < debian/patches/03_fonts.diff
- patch -p0 < debian/patches/04_fame.diff
- patch -p0 < debian/patches/05_icon.diff
- patch -p0 < debian/patches/06_srand.diff
- patch -p0 < debian/patches/07_long.diff
- patch -p0 < debian/patches/08_gcc43.diff
- patch -p0 < debian/patches/09_colors.diff
- patch -p0 < debian/patches/10_gcc43.diff
-
- uudecode debian/einstein.png.uue
- uudecode debian/icon.bmp.uue
- [ -f res/DejaVuSans.ttf ] || cp -p /usr/share/fonts/TTF/DejaVuSans.ttf res/
-}
+source=("git+git://github.com/lksj/einstein-puzzle.git"
+ "${pkgname}.desktop"
+ "${pkgname}.png")
+md5sums=('SKIP'
+ '4da7f4b1b17f7385ef2cb14fc6326997'
+ '81b58f2e3c61c0b50716992a30f2d4cc')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/einstein-puzzle"
make PREFIX=/usr
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/einstein-puzzle"
make PREFIX="${pkgdir}/usr" install
- install -Dm 644 "debian/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm 644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}
diff --git a/arch.patch b/arch.patch
deleted file mode 100644
index c40599ecf82e..000000000000
--- a/arch.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- einstein_2.0.dfsg.2-5.diff.orig 2013-01-26 17:23:38.297314526 +0100
-+++ einstein_2.0.dfsg.2-5.diff 2013-01-26 17:28:17.374267298 +0100
-@@ -961,7 +961,7 @@
-
- $(TARGET): $(OBJECTS)
- + cd mkres && make
--+ cd res && ../mkres/mkres --source resources.descr --output einstein.res
-++ cd res && ../mkres/mkres --source resources.descr --output ../einstein.res
- $(CXX) $(LNFLAGS) $(OBJECTS) -o $(TARGET)
-
- clean:
-@@ -971,13 +971,3 @@
-
- depend:
- @makedepend $(SOURCES) 2> /dev/null
--@@ -61,8 +65,7 @@
-- ./$(TARGET)
--
-- install: $(TARGET)
--- $(INSTALL) -s -D $(TARGET) $(PREFIX)/bin/$(TARGET)
--- $(INSTALL) -D einstein.res $(PREFIX)/share/einstein/res/einstein.res
--+ $(INSTALL) -s -D $(TARGET) $(DESTDIR)/$(PREFIX)/games/$(TARGET)
--
-- # DO NOT DELETE THIS LINE -- make depend depends on it.
--
diff --git a/einstein.desktop b/einstein.desktop
new file mode 100644
index 000000000000..c78bc96cee8b
--- /dev/null
+++ b/einstein.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=einstein.desktop
+GenericName=Puzzle Game
+Comment=Remake of old DOS game Sherlock which was inspired by Albert Einstein's puzzle.
+Exec=einstein
+Icon=einstein
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=Game;LogicGame;