summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerkin2021-02-16 06:14:18 +0300
committererkin2021-02-16 06:14:18 +0300
commit9a5ed21123205387a24d03ca6929205877a06aeb (patch)
tree631554ab040a538aab1d95b08b80bb0320d59119
parent2c10b924e5096e9049e2e98857070c233fd43ea9 (diff)
downloadaur-9a5ed21123205387a24d03ca6929205877a06aeb.tar.gz
Update to v1.7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2af2bd20945..886ebdfb5930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eisl
pkgdesc = Easy-ISLisp is an interpreter and compiler compatible with ISLisp standard.
- pkgver = 1.5
+ pkgver = 1.7
pkgrel = 1
url = https://github.com/sasagawa888/eisl
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = eisl
depends = sh
depends = gcc
depends = make
- source = https://github.com/sasagawa888/eisl/archive/v1.5.tar.gz
- sha256sums = 25670a105543babc5cb94a8d5ffe4b4a30f64087e3710929c6a17355a675ca89
+ source = https://github.com/sasagawa888/eisl/archive/v1.7.tar.gz
+ sha256sums = 7eb1a154b1d0cd11113ec3c45b4455a1a41b7d0558af4c13dd4237c2b4abdf3a
pkgname = eisl
diff --git a/PKGBUILD b/PKGBUILD
index 2f6cf9426b4d..50625394ebd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Erkin Batu Altunbaş <erkin@sdf.org>
pkgname=eisl
-pkgver=1.5
+pkgver=1.7
pkgrel=1
pkgdesc="Easy-ISLisp is an interpreter and compiler compatible with ISLisp standard."
arch=('x86_64' 'i686')
@@ -9,17 +9,11 @@ license=("custom")
depends=("sh" "gcc" "make")
source=("https://github.com/sasagawa888/eisl/archive/v${pkgver}.tar.gz")
-sha256sums=('25670a105543babc5cb94a8d5ffe4b4a30f64087e3710929c6a17355a675ca89')
+sha256sums=('7eb1a154b1d0cd11113ec3c45b4455a1a41b7d0558af4c13dd4237c2b4abdf3a')
package()
{
cd "$pkgname-$pkgver"
- make eisl
-
- install -d "$pkgdir/usr/share/$pkgname"
- cp -ra --no-preserve=ownership bench example test "$pkgdir/usr/share/$pkgname"
-
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
-
- install -Dm755 eisl "$pkgdir/usr/bin/eisl"
}