summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Williamson2018-08-31 16:26:19 -0400
committerMike Williamson2018-08-31 16:26:19 -0400
commit44c33ba3bca302750fdfe439cf17fc51836becb3 (patch)
treed45ddd3e95c26205b79abef19b611c60e133aa78
downloadaur-44c33ba3bca302750fdfe439cf17fc51836becb3.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
-rw-r--r--README.md4
4 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f9c434b426
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eksctl
+ pkgdesc = A simple CLI tool for creating clusters on Amazon's EKS
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://eksctl.io
+ arch = x86_64
+ license = APACHE
+ makedepends = binutils
+ provides = eksctl
+ source = https://github.com/weaveworks/eksctl/releases/download/0.1.1/eksctl_Linux_amd64.tar.gz
+ sha256sums = 3dd3db30bee6b29ce6cf914cad78a0ca50dc0de03fd14685138ac011040df8ec
+
+pkgname = eksctl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..da84ae61b399
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.swp
+*.xz
+*.tar.bz2
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd62596d1897
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Mike Williamson <mike at korora dot ca>
+pkgname=eksctl
+pkgdesc="A simple CLI tool for creating clusters on Amazon's EKS"
+pkgver=0.1.1
+pkgrel=1
+arch=('x86_64')
+license=("APACHE")
+url="https://eksctl.io"
+provides=('eksctl')
+makedepends=('binutils')
+source=("https://github.com/weaveworks/eksctl/releases/download/$pkgver/eksctl_Linux_amd64.tar.gz")
+sha256sums=('3dd3db30bee6b29ce6cf914cad78a0ca50dc0de03fd14685138ac011040df8ec')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m0755 "$srcdir"/eksctl "$pkgdir"/usr/bin/
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..951b57ca784b
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+# eksctl for Archlinux
+
+This is simple Archlinux packaging for the `eksctl` command from Weaveworks.
+For details see the [weaveworks/eksctl](https://github.com/weaveworks/eksctl) repo.