summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2020-04-27 12:45:02 -0400
committerDavid Birks2020-04-27 12:45:02 -0400
commit49eab1bf39aa1188c4b52ee69f72bffdb39f4733 (patch)
treea946973184411ef7bca6123daaea4aacbde87fdf
parenta043d3a26ae254b42057eef79ff683e3f9b2a1ec (diff)
downloadaur-49eab1bf39aa1188c4b52ee69f72bffdb39f4733.tar.gz
Update to 0.18.0
Also add the fish shell completions that are introduced in this release.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bf2fb426a1e..8dc66f647ae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eksctl
pkgdesc = Command line tool for creating clusters on Amazon EKS
- pkgver = 0.17.0
+ pkgver = 0.18.0
pkgrel = 1
url = https://github.com/weaveworks/eksctl
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = eksctl
makedepends = go
depends = kubectl
conflicts = eksctl-bin
- source = eksctl-0.17.0.tar.gz::https://github.com/weaveworks/eksctl/archive/0.17.0.tar.gz
- sha256sums = 9da30e2f3b19f02700007f21b828e88dbd46cdc26a6acc15064a716198343f3f
+ source = eksctl-0.18.0.tar.gz::https://github.com/weaveworks/eksctl/archive/0.18.0.tar.gz
+ sha256sums = c250c73f9caa462d132e886560c696b8a0ff7b9691a17525cc6b8eba87b5f51c
pkgname = eksctl
diff --git a/PKGBUILD b/PKGBUILD
index 64ab28e790b7..bff0a867e8c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=eksctl
pkgdesc='Command line tool for creating clusters on Amazon EKS'
-pkgver=0.17.0
+pkgver=0.18.0
pkgrel=1
arch=('x86_64')
license=('Apache')
@@ -12,7 +12,7 @@ depends=('kubectl')
makedepends=('go')
conflicts=('eksctl-bin')
source=("$pkgname-${pkgver/_/-}.tar.gz::https://github.com/weaveworks/eksctl/archive/${pkgver/_/-}.tar.gz")
-sha256sums=('9da30e2f3b19f02700007f21b828e88dbd46cdc26a6acc15064a716198343f3f')
+sha256sums=('c250c73f9caa462d132e886560c696b8a0ff7b9691a17525cc6b8eba87b5f51c')
build() {
# Trim PWD from binary
@@ -28,6 +28,8 @@ package() {
# Add command completion
install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
+ install -dm 755 "$pkgdir/usr/share/fish/completions"
"$pkgdir/usr/bin/eksctl" completion bash > "$pkgdir/usr/share/bash-completion/completions/eksctl"
"$pkgdir/usr/bin/eksctl" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_eksctl"
+ "$pkgdir/usr/bin/eksctl" completion fish > "$pkgdir/usr/share/fish/completions/eksctl.fish"
}