summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-04-10 22:42:46 +0200
committerhaawda2021-04-10 22:42:46 +0200
commitd771da87878dd086d591603fec6a0eb3544519c4 (patch)
tree4647053b9a70f78d2e419ca26c24bab2519485fa
downloadaur-d771da87878dd086d591603fec6a0eb3544519c4.tar.gz
initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..752c6ac63ccd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = elastic-git
+ pkgdesc = Simple yet efficient finite element solver for linear elasticity problems in two and three dimensions.
+ pkgver = 20190226.r136
+ pkgrel = 1
+ url = https://github.com/ISCDtoolbox/LinearElasticity
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = iscdcommons-git
+ depends = glibc
+ provides = elastic
+ conflicts = elastic
+ source = elastic::git+https://github.com/ISCDtoolbox/LinearElasticity.git
+ sha256sums = SKIP
+
+pkgname = elastic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f59df76d7a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=elastic-git
+pkgver=20190226.r136
+pkgrel=1
+pkgdesc="Simple yet efficient finite element solver for linear elasticity problems in two and three dimensions."
+arch=('x86_64')
+url="https://github.com/ISCDtoolbox/LinearElasticity"
+license=('LGPL')
+depends=('iscdcommons-git' 'glibc')
+makedepends=('git')
+conflicts=('elastic')
+provides=('elastic')
+source=("${pkgname%-git}::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "%s.r%s" $(git log -1 --format="%cd" --date=short | tr -d '-') \
+ "$(git rev-list --count HEAD)"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+ sed -i '4s+$ENV{HOME}+/usr+' CMakeLists.txt
+}
+
+build() {
+ cd ${pkgname%-git}
+ [[ -d build ]] || mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_SKIP_BUILD_RPATH:BOOL=TRUE
+ make
+}
+
+package() {
+ cd ${pkgname%-git}/build
+ install -Dm755 elastic "$pkgdir"/usr/bin/elastic
+ install -Dm644 libElas.so "$pkgdir"/usr/lib/libElas.so
+}