summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSid Karunaratne2015-06-08 17:17:50 +0300
committerSid Karunaratne2015-06-08 17:17:50 +0300
commit8c14f6ec3f2c99a7fbd69dac071b9a772776f573 (patch)
treeab479504dcef30216d1dff2dc6290bc6a9096563
downloadaur-elastic-mapreduce.tar.gz
Initial import, version 2014-07-22
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
-rw-r--r--elastic-mapreduce3
-rw-r--r--install26
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b19861c47d4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = elastic-mapreduce
+ pkgdesc = a pure Ruby client for the Amazon Elastic MapReduce Web Service.
+ pkgver = 20140722
+ pkgrel = 1
+ url = https://github.com/tc/elastic-mapreduce-ruby
+ install = install
+ arch = any
+ license = APACHE
+ makedepends = unzip
+ depends = ruby1.8
+ noextract = elastic-mapreduce-ruby.zip
+ source = http://elasticmapreduce.s3.amazonaws.com/elastic-mapreduce-ruby.zip
+ source = elastic-mapreduce
+ sha256sums = df1d718383a1f0c4680dcc1d1b553bfe25d0892e09ed85f8e0dbb1a3ce66aa1e
+ sha256sums = fdafdd3394bda33837898414c9880a35850c8070a51e4297d82832908002035a
+
+pkgname = elastic-mapreduce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..197cd8d16bd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sid Karunaratne <sid at karunaratne dot net>
+pkgname=elastic-mapreduce
+pkgver=20140722
+pkgrel=1
+pkgdesc="a pure Ruby client for the Amazon Elastic MapReduce Web Service."
+arch=('any')
+url="https://github.com/tc/elastic-mapreduce-ruby"
+license=('APACHE')
+source=("http://elasticmapreduce.s3.amazonaws.com/${pkgname}-ruby.zip"
+ "${pkgname}")
+noextract=("${pkgname}-ruby.zip")
+sha256sums=('df1d718383a1f0c4680dcc1d1b553bfe25d0892e09ed85f8e0dbb1a3ce66aa1e'
+ 'fdafdd3394bda33837898414c9880a35850c8070a51e4297d82832908002035a')
+depends=(ruby1.8)
+makedepends=(unzip)
+install=install
+
+build() {
+ cd "${srcdir}"
+ mkdir extracted
+ unzip "${pkgname}-ruby.zip" -d extracted
+ sed -i 's#/usr/bin/env ruby#/usr/bin/env ruby-1.8#' "extracted/${pkgname}"
+}
+
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/local/"
+ cp -r extracted "${pkgdir}/usr/local/${pkgname}"
+ install -Dm 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/elastic-mapreduce b/elastic-mapreduce
new file mode 100644
index 000000000000..2d9a5e68bfa2
--- /dev/null
+++ b/elastic-mapreduce
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /usr/local/elastic-mapreduce
+./elastic-mapreduce $@ \ No newline at end of file
diff --git a/install b/install
new file mode 100644
index 000000000000..d29f2e763d69
--- /dev/null
+++ b/install
@@ -0,0 +1,26 @@
+#!/bin/bash
+post_install()
+{
+cat<<EOF
+
+elastic-mapreduce expects you to have a credentials.json file in
+/usr/local/elastic-mapreduce. You should use the -c parameter to specify your
+own location. I suggest you place the following alias into your ~/.bashrc:
+alias elastic-mapreduce="elastic-mapreduce -c \$HOME/.config/elastic-mapreduce/credentials.json"
+
+These credentials are available on the http://aws.amazon.com website under
+"Your Account/Access Identifiers" (top right). The file should look something
+like this:
+
+$ cat credentials.json
+{
+ "access-id": "<insert your AWS access id here>",
+ "private-key": "<insert your AWS secret access key here>",
+ "key-pair": "<insert the name of your Amazon ec2 key-pair here>",
+ "key-pair-file": "<insert the path to the .pem file for your Amazon ec2 key pair here>",
+ "region": "<The region where you wish to launch your job flows. Should be one of us-east-1, us-west-1, us-west-2, eu-west-1, ap-southeast-1, or ap-northeast-1, sa-east-1>"
+}
+
+See /usr/local/elastic-mapreduce/README for more information
+EOF
+}