summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalachi Soord2023-07-12 10:54:25 +0200
committerMalachi Soord2023-07-12 10:54:25 +0200
commitae09ffa719ae2bc31edc00eab8631e340a18d21b (patch)
tree05396d092624f8719f530baa58db9c64db60dc75
downloadaur-ae09ffa719ae2bc31edc00eab8631e340a18d21b.tar.gz
Init
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 27 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b3c4a50cf11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = elastic-query-export-bin
+ pkgdesc = Export Data from ElasticSearch to CSV/JSON using a Lucene Query (e.g. from Kibana) or a raw JSON Query string.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/pteich/elastic-query-export
+ arch = x86_64
+ license = MIT
+ source = elastic-query-export-bin-1.5.0.tar.gz::https://github.com/pteich/elastic-query-export/releases/download/v1.5.0/elastic-query-export_1.5.0_Linux_x86_64.tar.gz
+ sha512sums = 93292ef47c8e143edce088a65a0224f8341dd3e40d688e0bd2718dc3ec9031868e32bc6ee5bedc37a119177e3d8881956a6dd8351d41f11dd959cb9b6bd9cf0d
+
+pkgname = elastic-query-export-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..711f1e6013a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Malachi Soord <me@malachisoord.com>
+
+pkgname=elastic-query-export-bin
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Export Data from ElasticSearch to CSV/JSON using a Lucene Query (e.g. from Kibana) or a raw JSON Query string."
+arch=('x86_64')
+url="https://github.com/pteich/elastic-query-export"
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/pteich/elastic-query-export/releases/download/v${pkgver}/elastic-query-export_${pkgver}_Linux_x86_64.tar.gz")
+sha512sums=('93292ef47c8e143edce088a65a0224f8341dd3e40d688e0bd2718dc3ec9031868e32bc6ee5bedc37a119177e3d8881956a6dd8351d41f11dd959cb9b6bd9cf0d')
+
+package() {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0755 elastic-query-export "$pkgdir/usr/bin/elastic-query-export"
+}