summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-01-22 11:07:16 +0100
committerMartino Pilia2018-01-22 11:07:16 +0100
commit226ff061378c2c83b9b53be03bc87d77bcdb9e06 (patch)
tree9d82c8c209bc62d87439bbffb9536db803536303
downloadaur-226ff061378c2c83b9b53be03bc87d77bcdb9e06.tar.gz
package submission
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD59
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1a23425c191
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = elastix
+ pkgdesc = Toolbox for rigid and nonrigid registration of images
+ pkgver = 4.8
+ pkgrel = 1
+ url = http://elastix.isi.uu.nl/
+ arch = x86_64
+ license = apache
+ makedepends = cmake
+ depends = insight-toolkit
+ conflicts = elastix-git
+ conflicts = elastix-bin
+ source = http://elastix.isi.uu.nl/download/elastix_sources_v4.8.tar.bz2
+ sha512sums = 9438285dfe153edb32ea9806bf3192123d1080ddc71437b3b2cc7006b18bcd8e875451e92293ab51275291a042513b8c4dad91292da4bd0897ed5ae05b6d6558
+
+pkgname = elastix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e5ac22feb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+pkgname=elastix
+pkgver=4.8
+pkgrel=1
+pkgdesc='Toolbox for rigid and nonrigid registration of images'
+arch=('x86_64')
+url='http://elastix.isi.uu.nl/'
+license=('apache')
+provides=()
+depends=('insight-toolkit')
+makedepends=('cmake')
+optdepends=()
+conflicts=('elastix-git' 'elastix-bin')
+source=('http://elastix.isi.uu.nl/download/elastix_sources_v4.8.tar.bz2')
+sha512sums=('9438285dfe153edb32ea9806bf3192123d1080ddc71437b3b2cc7006b18bcd8e875451e92293ab51275291a042513b8c4dad91292da4bd0897ed5ae05b6d6558')
+
+prepare() {
+ cd "${srcdir}/src"
+
+ mkdir build || :
+ cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" \
+ -DCMAKE_BUILD_TYPE:STRING=Release
+
+ # Make newer versions of ITK and gcc happy
+ sed -i '108i virtual const char * GetNameOfClass( void ) const\n;' \
+ "${srcdir}/src/Core/Install/elxBaseComponent.h"
+ sed -i '35iconst char * BaseComponent::GetNameOfClass( void ) const { return "BaseComponent"; }' \
+ "${srcdir}/src/Core/Install/elxBaseComponent.cxx"
+ sed -i '102s/inputImage/static_cast<const InputImageType *>(inputImage)/' \
+ "${srcdir}/src/Common/itkImageFileCastWriter.h"
+ sed -i '193,194s/vnl_math_min(/vnl_math_min( (int)/' \
+ "${srcdir}/src/Components/Optimizers/AdaptiveStochasticGradientDescent/elxAdaptiveStochasticGradientDescent.hxx"
+ sed -i '1009s/Generate/Update/' \
+ "${srcdir}/src/Core/Kernel/elxElastixMain.cxx"
+}
+
+build() {
+ cd "${srcdir}/src/build"
+ make
+}
+
+package() {
+ cd "${srcdir}/src/build"
+
+ make install
+
+ cd ..
+
+ install -D -m644 \
+ "LICENSE" \
+ "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+
+ install -D -m644 \
+ "NOTICE" \
+ "$pkgdir/usr/share/licenses/$_pkgname/NOTICE"
+}