summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm-pilia2018-07-08 08:30:17 +0200
committerm-pilia2018-07-08 08:30:17 +0200
commite0bc3c019e84e2a649e44897eea96d1d8d855c9b (patch)
tree50beb62fb85ceeb27c0416408ee184ffb99d6a66
parent76c3e595d0b116d4bdca285cf081849b20006eca (diff)
downloadaur-e0bc3c019e84e2a649e44897eea96d1d8d855c9b.tar.gz
build shared libs, config for SuperElastix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD115
2 files changed, 82 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c84c07eb5740..9aee61b82d80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = elastix
pkgdesc = Toolbox for rigid and nonrigid registration of images
pkgver = 4.9.0
- pkgrel = 1
+ pkgrel = 2
url = http://elastix.isi.uu.nl/
arch = x86_64
license = apache
diff --git a/PKGBUILD b/PKGBUILD
index 53c5efff69ae..a20333df4def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname=elastix
pkgver=4.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='Toolbox for rigid and nonrigid registration of images'
arch=('x86_64')
url='http://elastix.isi.uu.nl/'
@@ -20,50 +20,97 @@ prepare() {
mkdir "$_build_dir" || :
cd "$_build_dir"
- # What follows is the default CMake configuration.
- # I have listed all the components that are disabled by default, so
- # you can easily enable any extra you need!
cmake \
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DMAKE_CXX_FLAGS:STRING="--std=c++11" \
- -DELASTIX_USE_OPENCL:BOOL=OFF \
+ -DBUILD_TESTING:BOOL=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DELASTIX_BUILD_EXECUTABLE:BOOL=ON \
-DELASTIX_USE_ALL_COMPONENTS:BOOL=OFF \
+ -DELASTIX_USE_OPENCL:BOOL=OFF \
+ -DELASTIX_USE_OPENMP:BOOL=OFF \
-DELASTIX_USE_EIGEN:BOOL=OFF \
-DELASTIX_USE_OPENCL:BOOL=OFF \
- -DELASTIX_USE_AdvancedKappaStatisticMetric:BOOL=OFF \
- -DELASTIX_USE_AffineDTITransformElastix:BOOL=OFF \
+ -DELASTIX_USE_AdaptiveStochasticGradientDescent:BOOL=ON \
+ -DELASTIX_USE_AdvancedAffineTransformElastix:BOOL=ON \
+ -DELASTIX_USE_AdvancedBSplineTransform:BOOL=ON \
+ -DELASTIX_USE_AdvancedKappaStatisticMetric:BOOL=ON \
+ -DELASTIX_USE_AdvancedMattesMutualInformationMetric:BOOL=ON \
+ -DELASTIX_USE_AdvancedMeanSquaresMetric:BOOL=ON \
+ -DELASTIX_USE_AdvancedNormalizedCorrelationMetric:BOOL=ON \
+ -DELASTIX_USE_AffineDTITransformElastix:BOOL=ON \
-DELASTIX_USE_AffineLogTransformElastix:BOOL=OFF \
- -DELASTIX_USE_BSplineInterpolatorFloat:BOOL=OFF \
- -DELASTIX_USE_BSplineResampleInterpolatorFloat:BOOL=OFF \
- -DELASTIX_USE_BSplineTransformWidthDiffusion:BOOL=OFF \
- -DELASTIX_USE_CMAEvolutionStrategy:BOOL=OFF \
- -DELASTIX_USE_ConjugateGradientFRPR:BOOL=OFF \
- -DELASTIX_USE_DisplacementMagnitudePenaliy:BOOL=OFF \
- -DELASTIX_USE_FixedShrinkingPyramid:BOOL=OFF \
- -DELASTIX_USE_GradientDifferenceMetric:BOOL=OFF \
- -DELASTIX_USE_LinearResampleInterpolator:BOOL=OFF \
- -DELASTIX_USE_MissingStructurePenalty:BOOL=OFF \
- -DELASTIX_USE_MovingShrinkingPyramid:BOOL=OFF \
- -DELASTIX_USE_MultiBSplineTransformWithNormal:BOOL=OFF \
- -DELASTIX_USE_MutualInformationHistogramMetric:BOOL=OFF \
- -DELASTIX_USE_NearestNeighborInterpolator:BOOL=OFF \
- -DELASTIX_USE_NearestNeighborResampleInterpolator:BOOL=OFF \
- -DELASTIX_USE_NormalizedGradientCorrelationMetric:BOOL=OFF \
+ -DELASTIX_USE_BSplineInterpolator:BOOL=ON \
+ -DELASTIX_USE_BSplineInterpolatorFloat:BOOL=ON \
+ -DELASTIX_USE_BSplineResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_BSplineResampleInterpolatorFloat:BOOL=ON \
+ -DELASTIX_USE_BSplineStackTransform:BOOL=ON \
+ -DELASTIX_USE_BSplineTransformWithDiffusion:BOOL=ON \
+ -DELASTIX_USE_CMAEvolutionStrategy:BOOL=ON \
+ -DELASTIX_USE_CUDAResampler:BOOL=OFF \
+ -DELASTIX_USE_ConjugateGradient:BOOL=ON \
+ -DELASTIX_USE_ConjugateGradientFRPR:BOOL=ON \
+ -DELASTIX_USE_CorrespondingPointsEuclideanDistanceMetric:BOOL=ON \
+ -DELASTIX_USE_DeformationFieldTransform:BOOL=ON \
+ -DELASTIX_USE_DisplacementMagnitudePenalty:BOOL=ON \
+ -DELASTIX_USE_DistancePreservingRigidityPenalty:BOOL=ON \
+ -DELASTIX_USE_EulerTransformElastix:BOOL=ON \
+ -DELASTIX_USE_FiniteDifferenceGradientDescent:BOOL=ON \
+ -DELASTIX_USE_FixedGenericPyramid:BOOL=ON \
+ -DELASTIX_USE_FixedRecursivePyramid:BOOL=ON \
+ -DELASTIX_USE_FixedShrinkingPyramid:BOOL=ON \
+ -DELASTIX_USE_FixedSmoothingPyramid:BOOL=ON \
+ -DELASTIX_USE_FullSampler:BOOL=ON \
+ -DELASTIX_USE_FullSearch:BOOL=ON \
+ -DELASTIX_USE_GradientDifferenceMetric:BOOL=ON \
+ -DELASTIX_USE_GridSampler:BOOL=ON \
+ -DELASTIX_USE_KNNGraphAlphaMutualInformationMetric:BOOL=OFF \
+ -DELASTIX_USE_LinearInterpolator:BOOL=ON \
+ -DELASTIX_USE_LinearResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_MissingStructurePenalty:BOOL=ON \
+ -DELASTIX_USE_MovingRecursivePyramid:BOOL=ON \
+ -DELASTIX_USE_MovingShrinkingPyramid:BOOL=ON \
+ -DELASTIX_USE_MovingSmoothingPyramid:BOOL=ON \
+ -DELASTIX_USE_MultiBSplineTransformWithNormal:BOOL=ON \
+ -DELASTIX_USE_MultiInputRandomCoordinateSampler:BOOL=ON \
+ -DELASTIX_USE_MultiMetricMultiResolutionRegistration:BOOL=ON \
+ -DELASTIX_USE_MultiResolutionRegistration:BOOL=ON \
+ -DELASTIX_USE_MultiResolutionRegistrationWithFeatures:BOOL=ON \
+ -DELASTIX_USE_MutualInformationHistogramMetric:BOOL=ON \
+ -DELASTIX_USE_MyStandardResampler:BOOL=ON \
+ -DELASTIX_USE_NearestNeighborInterpolator:BOOL=ON \
+ -DELASTIX_USE_NearestNeighborResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_NormalizedGradientCorrelationMetric:BOOL=ON \
+ -DELASTIX_USE_NormalizedMutualInformationMetric:BOOL=ON \
-DELASTIX_USE_OpenCLFixedGenericPyramid:BOOL=OFF \
-DELASTIX_USE_OpenCLMovingGenericPyramid:BOOL=OFF \
-DELASTIX_USE_OpenCLResampler:BOOL=OFF \
- -DELASTIX_USE_PatternIntensityMetric:BOOL=OFF \
- -DELASTIX_USE_PolydataDummyPenalty:BOOL=OFF \
- -DELASTIX_USE_RSGDEEachParameterApart:BOOL=OFF \
- -DELASTIX_USE_RayCastInterpolator:BOOL=OFF \
- -DELASTIX_USE_RayCastResampleInterpolator:BOOL=OFF \
- -DELASTIX_USE_SimilarityTransformElastix:BOOL=OFF \
- -DELASTIX_USE_Simplex:BOOL=OFF \
- -DELASTIX_USE_SimultaneousPerturbation:BOOL=OFF \
- -DELASTIX_USE_StatisticalShapePenalty:BOOL=OFF \
- -DELASTIX_USE_ViolaWellsMutualInformationMetric:BOOL=OFF \
- -DELASTIX_USE_WeightedCombinationTransformElastix:BOOL=OFF \
+ -DELASTIX_USE_PatternIntensityMetric:BOOL=ON \
+ -DELASTIX_USE_PolydataDummyPenalty:BOOL=ON \
+ -DELASTIX_USE_Powell:BOOL=ON \
+ -DELASTIX_USE_QuasiNewtonLBFGS:BOOL=ON \
+ -DELASTIX_USE_RSGDEachParameterApart:BOOL=ON \
+ -DELASTIX_USE_RandomCoordinateSampler:BOOL=ON \
+ -DELASTIX_USE_RandomSampler:BOOL=ON \
+ -DELASTIX_USE_RandomSamplerSparseMask:BOOL=ON \
+ -DELASTIX_USE_RayCastInterpolator:BOOL=ON \
+ -DELASTIX_USE_RayCastResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_ReducedDimensionBSplineInterpolator:BOOL=ON \
+ -DELASTIX_USE_ReducedDimensionBSplineResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_RegularStepGradientDescent:BOOL=ON \
+ -DELASTIX_USE_SimilarityTransformElastix:BOOL=ON \
+ -DELASTIX_USE_Simplex:BOOL=ON \
+ -DELASTIX_USE_SimultaneousPerturbation:BOOL=ON \
+ -DELASTIX_USE_SplineKernelTransform:BOOL=ON \
+ -DELASTIX_USE_StandardGradientDescent:BOOL=ON \
+ -DELASTIX_USE_StatisticalShapePenalty:BOOL=ON \
+ -DELASTIX_USE_TransformBendingEnergyPenanalty:BOOL=ON \
+ -DELASTIX_USE_TransformRigidityPenalty:BOOL=ON \
+ -DELASTIX_USE_TranslationTransformElastix:BOOL=ON \
+ -DELASTIX_USE_VarianceOverLastDimensionMetric:BOOL=ON \
+ -DELASTIX_USE_ViolaWellsMutualInformationMetric:BOOL=ON \
+ -DELASTIX_USE_WeightedCombinationTransformElastix:BOOL=ON \
..
}