summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-01-22 08:37:05 +0100
committerMartino Pilia2018-01-22 08:37:05 +0100
commitee36c9cf11433510d39e6e3bb5dcf2440e7c2bec (patch)
tree717bc2a5ecbe790a4c393d36318d7bcbd61e1be6
downloadaur-ee36c9cf11433510d39e6e3bb5dcf2440e7c2bec.tar.gz
submit package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c2e5d141dcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = elastix-bin
+ pkgdesc = Toolbox for rigid and nonrigid registration of images
+ pkgver = 4.8
+ pkgrel = 1
+ url = http://elastix.isi.uu.nl/
+ arch = x86_64
+ license = apache
+ provides = elastix
+ conflicts = elastix-git
+ source = http://elastix.isi.uu.nl/download/elastix_linux64_v4.8.tar.bz2
+ sha512sums = 63d53cf5b9aad85046ef983948e5624c0b1e6b40b07e76b1388299a55ad634d970234fa2142518b7b70db425f5d58d622f532c58a4edc975ae31a1c383d5ca8f
+
+pkgname = elastix-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..709e24f1de31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=elastix
+pkgname=${_pkgname}-bin
+pkgver=4.8
+pkgrel=1
+pkgdesc='Toolbox for rigid and nonrigid registration of images'
+arch=('x86_64')
+url='http://elastix.isi.uu.nl/'
+license=('apache')
+provides=('elastix')
+depends=()
+makedepends=()
+optdepends=()
+conflicts=('elastix-git')
+source=('http://elastix.isi.uu.nl/download/elastix_linux64_v4.8.tar.bz2')
+sha512sums=('63d53cf5b9aad85046ef983948e5624c0b1e6b40b07e76b1388299a55ad634d970234fa2142518b7b70db425f5d58d622f532c58a4edc975ae31a1c383d5ca8f')
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${_pkgname}"
+
+ cp -r bin "${pkgdir}/usr/bin"
+ cp -r lib "${pkgdir}/usr/lib"
+
+ install -D -m644 \
+ "LICENSE" \
+ "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+
+ install -D -m644 \
+ "NOTICE" \
+ "$pkgdir/usr/share/licenses/$_pkgname/NOTICE"
+}
+