summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-08-11 16:34:57 +0200
committerMartino Pilia2018-08-11 16:34:57 +0200
commit0bf49407b371b0269d80e93517e73af01228c902 (patch)
tree6f183805a1df7101c0eb9a75e55ea1047498c4e6
parent6d91d80bcc42355d9ae696fea941924d753b9389 (diff)
downloadaur-0bf49407b371b0269d80e93517e73af01228c902.tar.gz
fixes in the build config
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD170
2 files changed, 85 insertions, 87 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11d6fe205d68..21967c25fc88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = elastix-git
pkgdesc = Toolbox for rigid and nonrigid registration of images
pkgver = 4.9.0.r0.g6e031631
- pkgrel = 3
+ pkgrel = 4
url = http://elastix.isi.uu.nl/
arch = x86_64
license = apache
diff --git a/PKGBUILD b/PKGBUILD
index 04d03bb518bd..b57c0f7cf424 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=elastix
pkgname=${_pkgname}-git
pkgver=4.9.0.r0.g6e031631
-pkgrel=3
+pkgrel=4
pkgdesc='Toolbox for rigid and nonrigid registration of images'
arch=('x86_64')
url='http://elastix.isi.uu.nl/'
@@ -32,97 +32,95 @@ prepare() {
cmake \
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
-DCMAKE_BUILD_TYPE:STRING=Release \
- -DMAKE_CXX_FLAGS:STRING="--std=c++11" \
+ -DCMAKE_CXX_FLAGS:STRING="--std=c++11" \
-DBUILD_TESTING:BOOL=OFF \
-DBUILD_SHARED_LIBS:BOOL=ON \
- -DELASTIX_IMAGE_2D_PIXELTYPES:STRING="short;float" \
- -DELASTIX_IMAGE_3D_PIXELTYPES:STRING="short;float" \
- -DELASTIX_IMAGE_4D_PIXELTYPES:STRING="short;float" \
+ -DELASTIX_IMAGE_2D_PIXELTYPES:STRING="unsigned char;short;float" \
+ -DELASTIX_IMAGE_3D_PIXELTYPES:STRING="unsigned char;short;float" \
+ -DELASTIX_IMAGE_4D_PIXELTYPES:STRING="unsigned char;short;float" \
-DELASTIX_BUILD_EXECUTABLE:BOOL=ON \
- -DELASTIX_USE_ALL_COMPONENTS:BOOL=OFF \
-DELASTIX_USE_OPENCL:BOOL=OFF \
-DELASTIX_USE_OPENMP:BOOL=OFF \
-DELASTIX_USE_EIGEN:BOOL=OFF \
- -DELASTIX_USE_OPENCL:BOOL=OFF \
- -DELASTIX_USE_AdaptiveStochasticGradientDescent:BOOL=ON \
- -DELASTIX_USE_AdvancedAffineTransformElastix:BOOL=ON \
- -DELASTIX_USE_AdvancedBSplineTransform:BOOL=ON \
- -DELASTIX_USE_AdvancedKappaStatisticMetric:BOOL=ON \
- -DELASTIX_USE_AdvancedMattesMutualInformationMetric:BOOL=ON \
- -DELASTIX_USE_AdvancedMeanSquaresMetric:BOOL=ON \
- -DELASTIX_USE_AdvancedNormalizedCorrelationMetric:BOOL=ON \
- -DELASTIX_USE_AffineDTITransformElastix:BOOL=ON \
- -DELASTIX_USE_AffineLogTransformElastix:BOOL=OFF \
- -DELASTIX_USE_BSplineInterpolator:BOOL=ON \
- -DELASTIX_USE_BSplineInterpolatorFloat:BOOL=ON \
- -DELASTIX_USE_BSplineResampleInterpolator:BOOL=ON \
- -DELASTIX_USE_BSplineResampleInterpolatorFloat:BOOL=ON \
- -DELASTIX_USE_BSplineStackTransform:BOOL=ON \
- -DELASTIX_USE_BSplineTransformWithDiffusion:BOOL=ON \
- -DELASTIX_USE_CMAEvolutionStrategy:BOOL=ON \
- -DELASTIX_USE_CUDAResampler:BOOL=OFF \
- -DELASTIX_USE_ConjugateGradient:BOOL=ON \
- -DELASTIX_USE_ConjugateGradientFRPR:BOOL=ON \
- -DELASTIX_USE_CorrespondingPointsEuclideanDistanceMetric:BOOL=ON \
- -DELASTIX_USE_DeformationFieldTransform:BOOL=ON \
- -DELASTIX_USE_DisplacementMagnitudePenalty:BOOL=ON \
- -DELASTIX_USE_DistancePreservingRigidityPenalty:BOOL=ON \
- -DELASTIX_USE_EulerTransformElastix:BOOL=ON \
- -DELASTIX_USE_FiniteDifferenceGradientDescent:BOOL=ON \
- -DELASTIX_USE_FixedGenericPyramid:BOOL=ON \
- -DELASTIX_USE_FixedRecursivePyramid:BOOL=ON \
- -DELASTIX_USE_FixedShrinkingPyramid:BOOL=ON \
- -DELASTIX_USE_FixedSmoothingPyramid:BOOL=ON \
- -DELASTIX_USE_FullSampler:BOOL=ON \
- -DELASTIX_USE_FullSearch:BOOL=ON \
- -DELASTIX_USE_GradientDifferenceMetric:BOOL=ON \
- -DELASTIX_USE_GridSampler:BOOL=ON \
- -DELASTIX_USE_KNNGraphAlphaMutualInformationMetric:BOOL=OFF \
- -DELASTIX_USE_LinearInterpolator:BOOL=ON \
- -DELASTIX_USE_LinearResampleInterpolator:BOOL=ON \
- -DELASTIX_USE_MissingStructurePenalty:BOOL=ON \
- -DELASTIX_USE_MovingRecursivePyramid:BOOL=ON \
- -DELASTIX_USE_MovingShrinkingPyramid:BOOL=ON \
- -DELASTIX_USE_MovingSmoothingPyramid:BOOL=ON \
- -DELASTIX_USE_MultiBSplineTransformWithNormal:BOOL=ON \
- -DELASTIX_USE_MultiInputRandomCoordinateSampler:BOOL=ON \
- -DELASTIX_USE_MultiMetricMultiResolutionRegistration:BOOL=ON \
- -DELASTIX_USE_MultiResolutionRegistration:BOOL=ON \
- -DELASTIX_USE_MultiResolutionRegistrationWithFeatures:BOOL=ON \
- -DELASTIX_USE_MutualInformationHistogramMetric:BOOL=ON \
- -DELASTIX_USE_MyStandardResampler:BOOL=ON \
- -DELASTIX_USE_NearestNeighborInterpolator:BOOL=ON \
- -DELASTIX_USE_NearestNeighborResampleInterpolator:BOOL=ON \
- -DELASTIX_USE_NormalizedGradientCorrelationMetric:BOOL=ON \
- -DELASTIX_USE_NormalizedMutualInformationMetric:BOOL=ON \
- -DELASTIX_USE_OpenCLFixedGenericPyramid:BOOL=OFF \
- -DELASTIX_USE_OpenCLMovingGenericPyramid:BOOL=OFF \
- -DELASTIX_USE_OpenCLResampler:BOOL=OFF \
- -DELASTIX_USE_PatternIntensityMetric:BOOL=ON \
- -DELASTIX_USE_PolydataDummyPenalty:BOOL=ON \
- -DELASTIX_USE_Powell:BOOL=ON \
- -DELASTIX_USE_QuasiNewtonLBFGS:BOOL=ON \
- -DELASTIX_USE_RSGDEachParameterApart:BOOL=ON \
- -DELASTIX_USE_RandomCoordinateSampler:BOOL=ON \
- -DELASTIX_USE_RandomSampler:BOOL=ON \
- -DELASTIX_USE_RandomSamplerSparseMask:BOOL=ON \
- -DELASTIX_USE_RayCastInterpolator:BOOL=ON \
- -DELASTIX_USE_RayCastResampleInterpolator:BOOL=ON \
- -DELASTIX_USE_ReducedDimensionBSplineInterpolator:BOOL=ON \
- -DELASTIX_USE_ReducedDimensionBSplineResampleInterpolator:BOOL=ON \
- -DELASTIX_USE_RegularStepGradientDescent:BOOL=ON \
- -DELASTIX_USE_SimilarityTransformElastix:BOOL=ON \
- -DELASTIX_USE_Simplex:BOOL=ON \
- -DELASTIX_USE_SimultaneousPerturbation:BOOL=ON \
- -DELASTIX_USE_SplineKernelTransform:BOOL=ON \
- -DELASTIX_USE_StandardGradientDescent:BOOL=ON \
- -DELASTIX_USE_StatisticalShapePenalty:BOOL=ON \
- -DELASTIX_USE_TransformBendingEnergyPenanalty:BOOL=ON \
- -DELASTIX_USE_TransformRigidityPenalty:BOOL=ON \
- -DELASTIX_USE_TranslationTransformElastix:BOOL=ON \
- -DELASTIX_USE_VarianceOverLastDimensionMetric:BOOL=ON \
- -DELASTIX_USE_ViolaWellsMutualInformationMetric:BOOL=ON \
- -DELASTIX_USE_WeightedCombinationTransformElastix:BOOL=ON \
+ -DUSE_ALL_COMPONENTS:BOOL=OFF \
+ -DUSE_AdaptiveStochasticGradientDescent:BOOL=ON \
+ -DUSE_AdvancedAffineTransformElastix:BOOL=ON \
+ -DUSE_AdvancedBSplineTransform:BOOL=ON \
+ -DUSE_AdvancedKappaStatisticMetric:BOOL=ON \
+ -DUSE_AdvancedMattesMutualInformationMetric:BOOL=ON \
+ -DUSE_AdvancedMeanSquaresMetric:BOOL=ON \
+ -DUSE_AdvancedNormalizedCorrelationMetric:BOOL=ON \
+ -DUSE_AffineDTITransformElastix:BOOL=ON \
+ -DUSE_AffineLogTransformElastix:BOOL=OFF \
+ -DUSE_BSplineInterpolator:BOOL=ON \
+ -DUSE_BSplineInterpolatorFloat:BOOL=ON \
+ -DUSE_BSplineResampleInterpolator:BOOL=ON \
+ -DUSE_BSplineResampleInterpolatorFloat:BOOL=ON \
+ -DUSE_BSplineStackTransform:BOOL=ON \
+ -DUSE_BSplineTransformWithDiffusion:BOOL=ON \
+ -DUSE_CMAEvolutionStrategy:BOOL=ON \
+ -DUSE_ConjugateGradient:BOOL=ON \
+ -DUSE_ConjugateGradientFRPR:BOOL=ON \
+ -DUSE_CorrespondingPointsEuclideanDistanceMetric:BOOL=ON \
+ -DUSE_DeformationFieldTransform:BOOL=ON \
+ -DUSE_DisplacementMagnitudePenalty:BOOL=ON \
+ -DUSE_DistancePreservingRigidityPenalty:BOOL=ON \
+ -DUSE_EulerTransformElastix:BOOL=ON \
+ -DUSE_FiniteDifferenceGradientDescent:BOOL=ON \
+ -DUSE_FixedGenericPyramid:BOOL=ON \
+ -DUSE_FixedRecursivePyramid:BOOL=ON \
+ -DUSE_FixedShrinkingPyramid:BOOL=ON \
+ -DUSE_FixedSmoothingPyramid:BOOL=ON \
+ -DUSE_FullSampler:BOOL=ON \
+ -DUSE_FullSearch:BOOL=ON \
+ -DUSE_GradientDifferenceMetric:BOOL=ON \
+ -DUSE_GridSampler:BOOL=ON \
+ -DUSE_KNNGraphAlphaMutualInformationMetric:BOOL=OFF \
+ -DUSE_LinearInterpolator:BOOL=ON \
+ -DUSE_LinearResampleInterpolator:BOOL=ON \
+ -DUSE_MissingStructurePenalty:BOOL=ON \
+ -DUSE_MovingRecursivePyramid:BOOL=ON \
+ -DUSE_MovingShrinkingPyramid:BOOL=ON \
+ -DUSE_MovingSmoothingPyramid:BOOL=ON \
+ -DUSE_MultiBSplineTransformWithNormal:BOOL=ON \
+ -DUSE_MultiInputRandomCoordinateSampler:BOOL=ON \
+ -DUSE_MultiMetricMultiResolutionRegistration:BOOL=ON \
+ -DUSE_MultiResolutionRegistration:BOOL=ON \
+ -DUSE_MultiResolutionRegistrationWithFeatures:BOOL=ON \
+ -DUSE_MutualInformationHistogramMetric:BOOL=ON \
+ -DUSE_MyStandardResampler:BOOL=ON \
+ -DUSE_NearestNeighborInterpolator:BOOL=ON \
+ -DUSE_NearestNeighborResampleInterpolator:BOOL=ON \
+ -DUSE_NormalizedGradientCorrelationMetric:BOOL=ON \
+ -DUSE_NormalizedMutualInformationMetric:BOOL=ON \
+ -DUSE_OpenCLFixedGenericPyramid:BOOL=OFF \
+ -DUSE_OpenCLMovingGenericPyramid:BOOL=OFF \
+ -DUSE_OpenCLResampler:BOOL=OFF \
+ -DUSE_PatternIntensityMetric:BOOL=ON \
+ -DUSE_PolydataDummyPenalty:BOOL=ON \
+ -DUSE_Powell:BOOL=ON \
+ -DUSE_QuasiNewtonLBFGS:BOOL=ON \
+ -DUSE_RSGDEachParameterApart:BOOL=ON \
+ -DUSE_RandomCoordinateSampler:BOOL=ON \
+ -DUSE_RandomSampler:BOOL=ON \
+ -DUSE_RandomSamplerSparseMask:BOOL=ON \
+ -DUSE_RayCastInterpolator:BOOL=ON \
+ -DUSE_RayCastResampleInterpolator:BOOL=ON \
+ -DUSE_ReducedDimensionBSplineInterpolator:BOOL=ON \
+ -DUSE_ReducedDimensionBSplineResampleInterpolator:BOOL=ON \
+ -DUSE_RegularStepGradientDescent:BOOL=ON \
+ -DUSE_SimilarityTransformElastix:BOOL=ON \
+ -DUSE_Simplex:BOOL=ON \
+ -DUSE_SimultaneousPerturbation:BOOL=ON \
+ -DUSE_SplineKernelTransform:BOOL=ON \
+ -DUSE_StandardGradientDescent:BOOL=ON \
+ -DUSE_StatisticalShapePenalty:BOOL=ON \
+ -DUSE_TransformBendingEnergyPenalty:BOOL=ON \
+ -DUSE_TransformRigidityPenalty:BOOL=ON \
+ -DUSE_TranslationTransformElastix:BOOL=ON \
+ -DUSE_VarianceOverLastDimensionMetric:BOOL=ON \
+ -DUSE_ViolaWellsMutualInformationMetric:BOOL=ON \
+ -DUSE_WeightedCombinationTransformElastix:BOOL=ON \
..
}