summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm-pilia2018-07-08 08:44:00 +0200
committerm-pilia2018-07-08 08:44:00 +0200
commit9d69ff77bd5bc5059b4b7f5c530c2b10fd0078a3 (patch)
treeb7e3e47ca82b14b91853d19e7c6095251ff5162a
parent2ed146ddb5f2b9a0851102b0dc27cd2675048396 (diff)
downloadaur-9d69ff77bd5bc5059b4b7f5c530c2b10fd0078a3.tar.gz
update post 4.9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD105
2 files changed, 97 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 493cf1828679..4b864dac859b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = elastix-git
pkgdesc = Toolbox for rigid and nonrigid registration of images
- pkgver = 4.304@3344.r945.g522843d9
- pkgrel = 3
+ pkgver = 4.9.0.r0.g6e031631
+ pkgrel = 2
url = http://elastix.isi.uu.nl/
arch = x86_64
license = apache
diff --git a/PKGBUILD b/PKGBUILD
index 085a7bffadcd..1bf5b3345f67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
_pkgname=elastix
pkgname=${_pkgname}-git
-pkgver=4.304@3344.r945.g522843d9
-pkgrel=3
+pkgver=4.9.0.r0.g6e031631
+pkgrel=2
pkgdesc='Toolbox for rigid and nonrigid registration of images'
arch=('x86_64')
url='http://elastix.isi.uu.nl/'
@@ -26,16 +26,101 @@ prepare() {
git checkout master
- # will not build with C++ 11
- sed -i '15iset(CMAKE_CXX_FLAGS_RELEASE "-std=c++03")' \
- CMakeLists.txt
-
mkdir build || :
cd build
- cmake .. \
+ cmake \
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
- -DCMAKE_BUILD_TYPE:STRING=Release
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DMAKE_CXX_FLAGS:STRING="--std=c++11" \
+ -DBUILD_TESTING:BOOL=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DELASTIX_BUILD_EXECUTABLE:BOOL=ON \
+ -DELASTIX_USE_ALL_COMPONENTS:BOOL=OFF \
+ -DELASTIX_USE_OPENCL:BOOL=OFF \
+ -DELASTIX_USE_OPENMP:BOOL=OFF \
+ -DELASTIX_USE_EIGEN:BOOL=OFF \
+ -DELASTIX_USE_OPENCL:BOOL=OFF \
+ -DELASTIX_USE_AdaptiveStochasticGradientDescent:BOOL=ON \
+ -DELASTIX_USE_AdvancedAffineTransformElastix:BOOL=ON \
+ -DELASTIX_USE_AdvancedBSplineTransform:BOOL=ON \
+ -DELASTIX_USE_AdvancedKappaStatisticMetric:BOOL=ON \
+ -DELASTIX_USE_AdvancedMattesMutualInformationMetric:BOOL=ON \
+ -DELASTIX_USE_AdvancedMeanSquaresMetric:BOOL=ON \
+ -DELASTIX_USE_AdvancedNormalizedCorrelationMetric:BOOL=ON \
+ -DELASTIX_USE_AffineDTITransformElastix:BOOL=ON \
+ -DELASTIX_USE_AffineLogTransformElastix:BOOL=OFF \
+ -DELASTIX_USE_BSplineInterpolator:BOOL=ON \
+ -DELASTIX_USE_BSplineInterpolatorFloat:BOOL=ON \
+ -DELASTIX_USE_BSplineResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_BSplineResampleInterpolatorFloat:BOOL=ON \
+ -DELASTIX_USE_BSplineStackTransform:BOOL=ON \
+ -DELASTIX_USE_BSplineTransformWithDiffusion:BOOL=ON \
+ -DELASTIX_USE_CMAEvolutionStrategy:BOOL=ON \
+ -DELASTIX_USE_CUDAResampler:BOOL=OFF \
+ -DELASTIX_USE_ConjugateGradient:BOOL=ON \
+ -DELASTIX_USE_ConjugateGradientFRPR:BOOL=ON \
+ -DELASTIX_USE_CorrespondingPointsEuclideanDistanceMetric:BOOL=ON \
+ -DELASTIX_USE_DeformationFieldTransform:BOOL=ON \
+ -DELASTIX_USE_DisplacementMagnitudePenalty:BOOL=ON \
+ -DELASTIX_USE_DistancePreservingRigidityPenalty:BOOL=ON \
+ -DELASTIX_USE_EulerTransformElastix:BOOL=ON \
+ -DELASTIX_USE_FiniteDifferenceGradientDescent:BOOL=ON \
+ -DELASTIX_USE_FixedGenericPyramid:BOOL=ON \
+ -DELASTIX_USE_FixedRecursivePyramid:BOOL=ON \
+ -DELASTIX_USE_FixedShrinkingPyramid:BOOL=ON \
+ -DELASTIX_USE_FixedSmoothingPyramid:BOOL=ON \
+ -DELASTIX_USE_FullSampler:BOOL=ON \
+ -DELASTIX_USE_FullSearch:BOOL=ON \
+ -DELASTIX_USE_GradientDifferenceMetric:BOOL=ON \
+ -DELASTIX_USE_GridSampler:BOOL=ON \
+ -DELASTIX_USE_KNNGraphAlphaMutualInformationMetric:BOOL=OFF \
+ -DELASTIX_USE_LinearInterpolator:BOOL=ON \
+ -DELASTIX_USE_LinearResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_MissingStructurePenalty:BOOL=ON \
+ -DELASTIX_USE_MovingRecursivePyramid:BOOL=ON \
+ -DELASTIX_USE_MovingShrinkingPyramid:BOOL=ON \
+ -DELASTIX_USE_MovingSmoothingPyramid:BOOL=ON \
+ -DELASTIX_USE_MultiBSplineTransformWithNormal:BOOL=ON \
+ -DELASTIX_USE_MultiInputRandomCoordinateSampler:BOOL=ON \
+ -DELASTIX_USE_MultiMetricMultiResolutionRegistration:BOOL=ON \
+ -DELASTIX_USE_MultiResolutionRegistration:BOOL=ON \
+ -DELASTIX_USE_MultiResolutionRegistrationWithFeatures:BOOL=ON \
+ -DELASTIX_USE_MutualInformationHistogramMetric:BOOL=ON \
+ -DELASTIX_USE_MyStandardResampler:BOOL=ON \
+ -DELASTIX_USE_NearestNeighborInterpolator:BOOL=ON \
+ -DELASTIX_USE_NearestNeighborResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_NormalizedGradientCorrelationMetric:BOOL=ON \
+ -DELASTIX_USE_NormalizedMutualInformationMetric:BOOL=ON \
+ -DELASTIX_USE_OpenCLFixedGenericPyramid:BOOL=OFF \
+ -DELASTIX_USE_OpenCLMovingGenericPyramid:BOOL=OFF \
+ -DELASTIX_USE_OpenCLResampler:BOOL=OFF \
+ -DELASTIX_USE_PatternIntensityMetric:BOOL=ON \
+ -DELASTIX_USE_PolydataDummyPenalty:BOOL=ON \
+ -DELASTIX_USE_Powell:BOOL=ON \
+ -DELASTIX_USE_QuasiNewtonLBFGS:BOOL=ON \
+ -DELASTIX_USE_RSGDEachParameterApart:BOOL=ON \
+ -DELASTIX_USE_RandomCoordinateSampler:BOOL=ON \
+ -DELASTIX_USE_RandomSampler:BOOL=ON \
+ -DELASTIX_USE_RandomSamplerSparseMask:BOOL=ON \
+ -DELASTIX_USE_RayCastInterpolator:BOOL=ON \
+ -DELASTIX_USE_RayCastResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_ReducedDimensionBSplineInterpolator:BOOL=ON \
+ -DELASTIX_USE_ReducedDimensionBSplineResampleInterpolator:BOOL=ON \
+ -DELASTIX_USE_RegularStepGradientDescent:BOOL=ON \
+ -DELASTIX_USE_SimilarityTransformElastix:BOOL=ON \
+ -DELASTIX_USE_Simplex:BOOL=ON \
+ -DELASTIX_USE_SimultaneousPerturbation:BOOL=ON \
+ -DELASTIX_USE_SplineKernelTransform:BOOL=ON \
+ -DELASTIX_USE_StandardGradientDescent:BOOL=ON \
+ -DELASTIX_USE_StatisticalShapePenalty:BOOL=ON \
+ -DELASTIX_USE_TransformBendingEnergyPenanalty:BOOL=ON \
+ -DELASTIX_USE_TransformRigidityPenalty:BOOL=ON \
+ -DELASTIX_USE_TranslationTransformElastix:BOOL=ON \
+ -DELASTIX_USE_VarianceOverLastDimensionMetric:BOOL=ON \
+ -DELASTIX_USE_ViolaWellsMutualInformationMetric:BOOL=ON \
+ -DELASTIX_USE_WeightedCombinationTransformElastix:BOOL=ON \
+ ..
}
build() {
@@ -51,10 +136,10 @@ package() {
cd ..
install -D -m644 \
- "src/LICENSE" \
+ "LICENSE" \
"$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
install -D -m644 \
- "src/NOTICE" \
+ "NOTICE" \
"$pkgdir/usr/share/licenses/$_pkgname/NOTICE"
}