summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-12-01 01:04:46 +0200
committerDimitris Kiziridis2020-12-01 01:04:46 +0200
commit9f9fb27847f8f837ff6b7d32280e55f2d3e91507 (patch)
treeb5f6f5ee097bf448f4241dc6df44cfb1631b2232
downloadaur-9f9fb27847f8f837ff6b7d32280e55f2d3e91507.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e90e2d5cb04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = electorrent-bin
+ pkgdesc = A remote control client for µTorrent, qBittorrent, rTorrent, Transmission, Synology & Deluge
+ pkgver = 2.7.1
+ pkgrel = 1
+ url = https://github.com/Tympanix/Electorrent
+ arch = x86_64
+ license = GPL3
+ makedepends = gendesk
+ provides = electorrent
+ conflicts = electorrent
+ noextract = electorrent-2.7.1.AppImage
+ source = electorrent-2.7.1.AppImage::https://github.com/tympanix/Electorrent/releases/download/v2.7.1/Electorrent-2.7.1.AppImage
+ sha256sums = 3197b0373667dee043b7a649dbb9a41884fd0726c49d6bfa303a50273d9309db
+
+pkgname = electorrent-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a62e64366d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=electorrent-bin
+pkgver=2.7.1
+pkgrel=1
+pkgdesc="A remote control client for µTorrent, qBittorrent, rTorrent, Transmission, Synology & Deluge"
+arch=('x86_64')
+url='https://github.com/Tympanix/Electorrent'
+license=('GPL3')
+provides=('electorrent')
+conflicts=('electorrent')
+makedepends=('gendesk')
+noextract=("${pkgname%-bin}-${pkgver}.AppImage")
+source=("${pkgname%-bin}-${pkgver}.AppImage::https://github.com/tympanix/Electorrent/releases/download/v${pkgver}/Electorrent-${pkgver}.AppImage")
+sha256sums=('3197b0373667dee043b7a649dbb9a41884fd0726c49d6bfa303a50273d9309db')
+
+package() {
+ chmod 755 ./${pkgname%-bin}-${pkgver}.AppImage
+ ./${pkgname%-bin}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/512x512/apps/electorrent.png "${pkgdir}/usr/share/pixmaps/electorrent.png"
+ gendesk -f -n --pkgname "${pkgname%-bin}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Electorrent" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname%-bin}" \
+ --categories 'Utility;Network;Application' \
+ --icon "${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname%-bin}"
+ ln -s /opt/${pkgname%-bin}/AppRun "${pkgdir}/usr/bin/electorrent"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} +
+}