summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2024-03-02 18:05:38 +0100
committerClaudia Pellegrino2024-03-02 18:08:01 +0100
commit91ff2ba28f2ab018c61413444887fa54e2cdb4ab (patch)
treec83ce7bda80cadad3bb84c52303baf9e8d978b3e
parentfc384fa96db47a993e5e99debffd7f4a6fb441cc (diff)
downloadaur-91ff2ba28f2ab018c61413444887fa54e2cdb4ab.tar.gz
Remove `spotify-blur-me-not`
The AUR package `spotify` now supports a native flags file, so the `spotify-blur-me-not` package is no longer necessary. Users should remove it and use a `spotify-flags.conf` instead.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
-rw-r--r--spotify-blur-me-not.install14
-rw-r--r--spotify-flags.conf3
4 files changed, 10 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aff708061a3..677b3fe80f04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-blur-me-not
pkgdesc = Auto-enable Wayland (ozone) for apps that come with a vendored Electron
- pkgver = 0.1.5
- pkgrel = 2
+ pkgver = 0.1.6
+ pkgrel = 1
url = https://aur.archlinux.org/pkgbase/electron-blur-me-not
arch = any
license = Apache
@@ -10,13 +10,11 @@ pkgbase = electron-blur-me-not
source = electron-blur-me-not-patch.sh
source = electron-blur-me-not-unpatch.sh
source = electron-flags.conf
- source = spotify-flags.conf
source = electron-launcher.sh
sha512sums = 5057477e2155a61a110a106e66376137f19472df215383435885529f6d8fbdc533ad912cb6a964cc2c8112d93f2443540729c3877b2259268729040c860f4506
sha512sums = 723e199194d1a000ed8a4802e7db14dee10bc34f55c10c89630ae9d84be9086b2ec6beb2a5bd805335a13384896b542e71a15c7e0a1b507862ce2c6ada1e46de
sha512sums = f9bed1185af1a409d6dfef9d9b46c5765ce9ac168385934be52d7e7fe4dd8f688116cc5dc7bf8f09c2620f229bd8fd696959748e0d044928ff281a4ef023be67
sha512sums = d24eedac69f293f51a23e9d998b880b849554eb150777809c5f041009493aa99282b2c458fff71c9e14e6bd75b34d85c61cee3f3b9b62573faf411be157d0148
- sha512sums = 0e9a508c502015145428a96400166efb809f8bd3a9a312dac111c3cd051720bd78e602c78677593f68fc22ee0bd195129735f772234296c815200b88a8fbfbd9
sha512sums = fe94d357a5da3333beaa88d1dc9a02b75c6d07ab83d32029f8ac216e783cfc8a90f4bdad2b6e01a10d796228acface0896240528811def3cfee70c13d40807d1
pkgname = 1password-blur-me-not
@@ -38,7 +36,3 @@ pkgname = rambox-pro-bin-blur-me-not
pkgname = signal-desktop-blur-me-not
pkgdesc = Auto-enable Wayland (ozone) for signal-desktop
depends = signal-desktop
-
-pkgname = spotify-blur-me-not
- pkgdesc = Auto-enable Wayland (ozone) for spotify
- depends = spotify
diff --git a/PKGBUILD b/PKGBUILD
index 839a71841202..5d08eccd41bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,13 @@ pkgname=(
'element-desktop-blur-me-not'
'rambox-pro-bin-blur-me-not'
'signal-desktop-blur-me-not'
- 'spotify-blur-me-not'
+ # 'spotify' -- create a `spotify-flags.conf` file instead, but
+ # use `--ozone-platform=wayland`, not `--ozone-platform-hint=auto`,
+ # due to the legacy Electron version vendored with the Spotify app
)
-pkgver=0.1.5
-pkgrel=2
+pkgver=0.1.6
+pkgrel=1
pkgdesc='Auto-enable Wayland (ozone) for apps that come with a vendored Electron'
arch=('any')
url='https://aur.archlinux.org/pkgbase/electron-blur-me-not'
@@ -31,7 +33,6 @@ source=(
"${pkgbase}-patch.sh"
"${pkgbase}-unpatch.sh"
'electron-flags.conf'
- 'spotify-flags.conf'
'electron-launcher.sh'
)
@@ -40,7 +41,6 @@ sha512sums=(
'723e199194d1a000ed8a4802e7db14dee10bc34f55c10c89630ae9d84be9086b2ec6beb2a5bd805335a13384896b542e71a15c7e0a1b507862ce2c6ada1e46de'
'f9bed1185af1a409d6dfef9d9b46c5765ce9ac168385934be52d7e7fe4dd8f688116cc5dc7bf8f09c2620f229bd8fd696959748e0d044928ff281a4ef023be67'
'd24eedac69f293f51a23e9d998b880b849554eb150777809c5f041009493aa99282b2c458fff71c9e14e6bd75b34d85c61cee3f3b9b62573faf411be157d0148'
- '0e9a508c502015145428a96400166efb809f8bd3a9a312dac111c3cd051720bd78e602c78677593f68fc22ee0bd195129735f772234296c815200b88a8fbfbd9'
'fe94d357a5da3333beaa88d1dc9a02b75c6d07ab83d32029f8ac216e783cfc8a90f4bdad2b6e01a10d796228acface0896240528811def3cfee70c13d40807d1'
)
@@ -59,17 +59,9 @@ _package() {
"${pkgdir}/usr/share/libalpm/hooks" \
"${pkgdir}/usr/share/libalpm/scripts"
- if [ -e "${srcdir}/${pkgname%-blur-me-not}-flags.conf" ]; then
- # App-specific flags
- install -D -m 644 -T \
- "${srcdir}/${pkgname%-blur-me-not}-flags.conf" \
- "${pkgdir}/etc/${pkgname%-blur-me-not}-flags.conf"
- else
- # Generic flags
- install -D -m 644 -T \
- "${srcdir}/electron-flags.conf" \
- "${pkgdir}/etc/${pkgname%-blur-me-not}-flags.conf"
- fi
+ install -D -m 644 -T \
+ "${srcdir}/electron-flags.conf" \
+ "${pkgdir}/etc/${pkgname%-blur-me-not}-flags.conf"
sed \
-e "s/{{basename}}/${pkgname%-blur-me-not}/g" \
@@ -132,9 +124,3 @@ package_signal-desktop-blur-me-not() {
pkgdesc="$(_pkgdesc 'Signal Desktop')"
_package '/usr/lib/signal-desktop/signal-desktop'
}
-
-package_spotify-blur-me-not() {
- depends=("${pkgname%-blur-me-not}")
- pkgdesc="$(_pkgdesc 'Spotify')"
- _package '/opt/spotify/spotify'
-}
diff --git a/spotify-blur-me-not.install b/spotify-blur-me-not.install
deleted file mode 100644
index aa413d8adb76..000000000000
--- a/spotify-blur-me-not.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- echo >&2 'Enabling Wayland (ozone) for spotify...'
- /usr/share/libalpm/scripts/spotify-blur-me-not-patch
-}
-
-post_upgrade() {
- echo >&2 'Enabling Wayland (ozone) for spotify...'
- /usr/share/libalpm/scripts/spotify-blur-me-not-patch
-}
-
-pre_remove() {
- echo >&2 'Undoing modifications to spotify...'
- /usr/share/libalpm/scripts/spotify-blur-me-not-unpatch
-}
diff --git a/spotify-flags.conf b/spotify-flags.conf
deleted file mode 100644
index 5ab6ca69cef6..000000000000
--- a/spotify-flags.conf
+++ /dev/null
@@ -1,3 +0,0 @@
---enable-features=WaylandWindowDecorations
-# Spotify still requires the `--ozone-platform` legacy switch
---ozone-platform=wayland