summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-11 10:13:21 +0800
committerzxp198210052024-01-11 10:13:21 +0800
commit6f7525c2f9b8468cec9126fd82d5e092c008e332 (patch)
tree92d635d43183ea985cf74862e82e2518c1430e6f
parentd741d68613f1fd2ec64015c59304b8e1b1ba5cd2 (diff)
downloadaur-6f7525c2f9b8468cec9126fd82d5e092c008e332.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--electron-calculator.sh8
3 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9781f744bc94..087da90c1a7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-calculator-bin
pkgdesc = Simple electron calculator app
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Alex313031/electron-calculator
arch = x86_64
license = BSD
@@ -12,8 +12,8 @@ pkgbase = electron-calculator-bin
source = electron-calculator-1.1.2.deb::https://github.com/Alex313031/electron-calculator/releases/download/1.1.2/electron-calculator_1.1.2_amd64.deb
source = LICENSE-1.1.2::https://raw.githubusercontent.com/Alex313031/electron-calculator/1.1.2/LICENSE
source = electron-calculator.sh
- sha256sums = ac91977fb127e39364703456ce79c08c4d469f62676b762f0bc4d72afbe148eb
+ sha256sums = a24c56eb012c763c6c10ddf137ff4c72c0d8898776083baed52085bb78023664
sha256sums = 0971f64facd7071ec5e71edbac78a59937e0a82e1b1599ee45e5ce0e4735623e
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = electron-calculator-bin
diff --git a/PKGBUILD b/PKGBUILD
index 96c001b4dbee..ea0fb895cdd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=electron-calculator-bin
_pkgname="Electron Calculator"
pkgver=1.1.2
_electronversion=22
-pkgrel=1
+pkgrel=2
pkgdesc="Simple electron calculator app"
arch=('x86_64')
url="https://github.com/Alex313031/electron-calculator"
@@ -19,9 +19,9 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/Alex313031/electron-calculator/${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('ac91977fb127e39364703456ce79c08c4d469f62676b762f0bc4d72afbe148eb'
+sha256sums=('a24c56eb012c763c6c10ddf137ff4c72c0d8898776083baed52085bb78023664'
'0971f64facd7071ec5e71edbac78a59937e0a82e1b1599ee45e5ce0e4735623e'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/electron-calculator.sh b/electron-calculator.sh
index c77c53567639..aacd8f895847 100644
--- a/electron-calculator.sh
+++ b/electron-calculator.sh
@@ -6,12 +6,10 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
- exit
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file