summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel O'Neil2019-03-27 23:23:56 -0400
committerMarcel O'Neil2019-03-27 23:23:56 -0400
commit390c8f8c9dc652e5e279900bdbcd9b06b8815a57 (patch)
tree0c8b9bdca27970ee36b8ea07f4c966f0530cbad8
parentaeb3aaeab97499c7b8e71cd1398a51bff442bec7 (diff)
downloadaur-390c8f8c9dc652e5e279900bdbcd9b06b8815a57.tar.gz
4.0.0 w/ PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58b655193b72..30f27084982b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electron-cash
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 3.3.6
+ pkgver = 4.0.0
pkgrel = 1
url = http://www.electroncash.org/
arch = any
@@ -11,6 +11,7 @@ pkgbase = electron-cash
makedepends = python-setuptools
makedepends = python-tox
depends = hicolor-icon-theme
+ depends = libsecp256k1
depends = python
depends = python-dnspython
depends = python-ecdsa
@@ -23,19 +24,19 @@ pkgbase = electron-cash
depends = python-requests
depends = python-six
depends = qt5-base
- optdepends = desktop-file-utils: update desktop icon
- optdepends = gtk-update-icon-cache: update desktop icon
optdepends = python-btchip: Ledger hardware wallet support
optdepends = python-hidapi: Digital Bitbox hardware wallet support
- optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
optdepends = python-matplotlib: plot transaction history in graphical mode
+ optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
+ optdepends = python-qdarkstyle: optional dark theme in graphical mode
optdepends = python-rpyc: send commands to Electrum Python console from an external script
- optdepends = xdg-utils: update desktop icon
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
- source = electron-cash-3.3.6.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/3.3.6.tar.gz
- sha256sums = 470dc7c200045ffade3bc45aa2ba0042fad0c23b9dfac6a52b7dcb6466c4870f
+ source = electron-cash-4.0.0.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/4.0.0.tar.gz
+ source = 0001-setup.py-option-to-disable-secp-build.patch
+ sha256sums = 5db277fbd81cf30e6b21fb7dc0a25da90f566d084b65ce727b91aef90fff672e
+ sha256sums = 3a201d65a364a1f6290c19269f7e4cd79f08af86da851a93d1b0e9d5e79d2d3c
pkgname = electron-cash
diff --git a/PKGBUILD b/PKGBUILD
index 8034b5b6efdd..3c01d357ee24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=3.3.6
+pkgver=4.0.0
pkgrel=1
url='http://www.electroncash.org/'
arch=('any')
@@ -20,6 +20,7 @@ makedepends=(
)
depends=(
'hicolor-icon-theme'
+ 'libsecp256k1'
'python'
'python-dnspython'
'python-ecdsa'
@@ -34,23 +35,29 @@ depends=(
'qt5-base'
)
optdepends=(
- 'desktop-file-utils: update desktop icon'
- 'gtk-update-icon-cache: update desktop icon'
'python-btchip: Ledger hardware wallet support'
'python-hidapi: Digital Bitbox hardware wallet support'
- 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
'python-matplotlib: plot transaction history in graphical mode'
+ 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
+ 'python-qdarkstyle: optional dark theme in graphical mode'
'python-rpyc: send commands to Electrum Python console from an external script'
- 'xdg-utils: update desktop icon'
'zbar: QR code reading support'
)
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/${pkgver/.0}.tar.gz")
-sha256sums=('470dc7c200045ffade3bc45aa2ba0042fad0c23b9dfac6a52b7dcb6466c4870f')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/${pkgver}.tar.gz"
+ "0001-setup.py-option-to-disable-secp-build.patch")
+sha256sums=('5db277fbd81cf30e6b21fb7dc0a25da90f566d084b65ce727b91aef90fff672e'
+ '3a201d65a364a1f6290c19269f7e4cd79f08af86da851a93d1b0e9d5e79d2d3c')
+
+prepare() {
+ cd "Electron-Cash-${pkgver}"
+
+ patch -Np1 -i "${srcdir}/0001-setup.py-option-to-disable-secp-build.patch"
+}
build() {
- cd "Electron-Cash-${pkgver/.0}"
+ cd "Electron-Cash-${pkgver}"
# python2-pyqt5 and qt5-base are needed for _only_ the icons...
@@ -65,13 +72,14 @@ build() {
}
check() {
- cd "Electron-Cash-${pkgver/.0}"
+ cd "Electron-Cash-${pkgver}"
- tox -e py37
+ python setup.py sdist --format=gztar --disable-secp
+ tox -e py37 --installpkg "dist/Electron Cash-${pkgver}.tar.gz"
}
package() {
- cd "Electron-Cash-${pkgver/.0}"
+ cd "Electron-Cash-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}