summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-12-09 00:10:01 -0600
committerDan Beste2017-12-09 00:10:01 -0600
commit499f4f5b840e8d2b52125f6509a010554590631d (patch)
treedd96d803c5d4df7359b03871c18a65e6ef3098fa
parent821c45af123091bee7342e26716dc77bc6b32989 (diff)
downloadaur-499f4f5b840e8d2b52125f6509a010554590631d.tar.gz
v3.0.0
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD67
2 files changed, 54 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1b0c36d404c..35d598a71207 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,48 +1,43 @@
pkgbase = electron-cash
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 2.9.4
- pkgrel = 2
+ pkgver = 3.0.0
+ pkgrel = 1
url = http://www.electroncash.org/
install = electron-cash.install
arch = any
license = MIT
makedepends = git
makedepends = protobuf
- makedepends = python2-pycurl
- makedepends = python2-setuptools
- makedepends = python2-tox
+ makedepends = python-pycurl
+ makedepends = python-setuptools
+ makedepends = python-tox
depends = hicolor-icon-theme
- depends = python2
- depends = python2-dnspython
- depends = python2-ecdsa
- depends = python2-jsonrpclib-pelix
- depends = python2-pbkdf2
- depends = python2-protobuf
- depends = python2-pyaes
- depends = python2-pyqt4
- depends = python2-pyqt5
- depends = python2-pysocks
- depends = python2-qrcode
- depends = python2-requests
- depends = python2-six
- depends = qt4
+ depends = python
+ depends = python-dnspython
+ depends = python-ecdsa
+ depends = python-jsonrpclib-pelix
+ depends = python-pbkdf2
+ depends = python-protobuf
+ depends = python-pyaes
+ depends = python-pyqt5
+ depends = python-pysocks
+ depends = python-qrcode
+ depends = python-requests
+ depends = python-six
depends = qt5-base
optdepends = desktop-file-utils: update desktop icon
optdepends = gtk-update-icon-cache: update desktop icon
- optdepends = python2-amodem: air-gapped transaction signing over audio modem
- optdepends = python2-btchip: Ledger hardware wallet support
- optdepends = python2-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
- optdepends = python2-keepkey: KeepKey hardware wallet support
- optdepends = python2-matplotlib: plot transaction history in graphical mode
- optdepends = python2-rpyc: send commands to Electrum Python console from an external script
- optdepends = python2-trezor: Trezor hardware wallet support
+ optdepends = python-btchip: Ledger hardware wallet support
+ optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
+ optdepends = python-matplotlib: plot transaction history in graphical mode
+ optdepends = python-rpyc: send commands to Electrum Python console from an external script
optdepends = xdg-utils: update desktop icon
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
- source = electron-cash-2.9.4.tar.gz::https://github.com/fyookball/electrum/archive/2.9.4.tar.gz
+ source = electron-cash-3.0.0.tar.gz::https://github.com/fyookball/electrum/archive/3.0.tar.gz
source = electron-cash.install
- sha256sums = f14c06a71ba97d1f39faa3cfcaba779f6f03ab8d44a9e3f7971d0bced3ea03b7
+ sha256sums = cda2667d937f7ce5b82c2e31111059f5c47eb65a9ea2d9682ce7f3c987032775
sha256sums = d682766321f9981ee38aee26dc050209882d8c1c6006e3e509649b47fa1bb073
pkgname = electron-cash
diff --git a/PKGBUILD b/PKGBUILD
index cc1c9e0e9cec..400c61eaecc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=2.9.4
-pkgrel=2
+pkgver=3.0.0
+pkgrel=1
url='http://www.electroncash.org/'
install="${pkgname}.install"
arch=('any')
@@ -19,38 +19,33 @@ license=('MIT')
makedepends=(
'git'
'protobuf'
- 'python2-pycurl'
- 'python2-setuptools'
- 'python2-tox'
+ 'python-pycurl'
+ 'python-setuptools'
+ 'python-tox'
)
depends=(
'hicolor-icon-theme'
- 'python2'
- 'python2-dnspython'
- 'python2-ecdsa'
- 'python2-jsonrpclib-pelix'
- 'python2-pbkdf2'
- 'python2-protobuf'
- 'python2-pyaes'
- 'python2-pyqt4'
- 'python2-pyqt5'
- 'python2-pysocks'
- 'python2-qrcode'
- 'python2-requests'
- 'python2-six'
- 'qt4'
+ 'python'
+ 'python-dnspython'
+ 'python-ecdsa'
+ 'python-jsonrpclib-pelix'
+ 'python-pbkdf2'
+ 'python-protobuf'
+ 'python-pyaes'
+ 'python-pyqt5'
+ 'python-pysocks'
+ 'python-qrcode'
+ 'python-requests'
+ 'python-six'
'qt5-base'
)
optdepends=(
'desktop-file-utils: update desktop icon'
'gtk-update-icon-cache: update desktop icon'
- 'python2-amodem: air-gapped transaction signing over audio modem'
- 'python2-btchip: Ledger hardware wallet support'
- 'python2-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
- 'python2-keepkey: KeepKey hardware wallet support'
- 'python2-matplotlib: plot transaction history in graphical mode'
- 'python2-rpyc: send commands to Electrum Python console from an external script'
- 'python2-trezor: Trezor hardware wallet support'
+ 'python-btchip: Ledger hardware wallet support'
+ 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
+ 'python-matplotlib: plot transaction history in graphical mode'
+ 'python-rpyc: send commands to Electrum Python console from an external script'
'xdg-utils: update desktop icon'
'zbar: QR code reading support'
)
@@ -58,39 +53,39 @@ provides=("${pkgname}")
conflicts=("${pkgname}")
install="${pkgname}.install"
source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/fyookball/electrum/archive/${pkgver}.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/fyookball/electrum/archive/${pkgver/.0}.tar.gz"
"${pkgname}.install"
)
sha256sums=(
- 'f14c06a71ba97d1f39faa3cfcaba779f6f03ab8d44a9e3f7971d0bced3ea03b7'
+ 'cda2667d937f7ce5b82c2e31111059f5c47eb65a9ea2d9682ce7f3c987032775'
'd682766321f9981ee38aee26dc050209882d8c1c6006e3e509649b47fa1bb073'
)
build() {
- cd "${pkgname/on-cash/um}-${pkgver}"
+ cd "${pkgname/on-cash/um}-${pkgver/.0}"
# python2-pyqt5 and qt5-base are needed for _only_ the icons...
# Compile the icons file for Qt:
- python2-pyrcc5 icons.qrc -o gui/qt/icons_rc.py
+ pyrcc5 icons.qrc -o gui/qt/icons_rc.py
# Compile the protobuf description file:
protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
# Create translations (optional):
- python2 contrib/make_locale
+ python contrib/make_locale
# Build
- python2 setup.py build
+ python setup.py build
}
check() {
- cd "${pkgname/on-cash/um}-${pkgver}"
+ cd "${pkgname/on-cash/um}-${pkgver/.0}"
- tox2
+ tox -e py36
}
package() {
- cd "${pkgname/on-cash/um}-${pkgver}"
+ cd "${pkgname/on-cash/um}-${pkgver/.0}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1
}