summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-11-10 13:17:12 -0600
committerDan Beste2017-11-10 13:17:12 -0600
commit649b700bcb7827ed8a423bab837549044785671f (patch)
treeb0595e5f622f69dfda89048134907a6b70340213
parente70c9e974af7c8fd3cd63ed549a46e96987bf101 (diff)
downloadaur-649b700bcb7827ed8a423bab837549044785671f.tar.gz
v2.9.4
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD42
-rw-r--r--electron-cash-2.9.4.tar.gz.sigbin0 -> 96 bytes
4 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca8ffb7e434c..6e740b8bad8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-cash
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 2.9.3
- pkgrel = 2
+ pkgver = 2.9.4
+ pkgrel = 1
url = http://www.electroncash.org/
install = electron-cash.install
arch = any
@@ -38,8 +38,10 @@ pkgbase = electron-cash
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
- source = electron-cash-2.9.3.tar.gz::https://github.com/fyookball/electrum/archive/2.9.3.tar.gz
- sha256sums = 406bc77c9a6f8a1fb69cdbe2873ad6fb2956afbb6ec0f1da71b9d6ee9f8bf8bc
+ source = electron-cash-2.9.4.tar.gz::https://electroncash.org/downloads/2.9.4/win-linux/Electron-Cash-2.9.4.tar.gz
+ source = electron-cash-2.9.4.tar.gz.sig
+ sha256sums = 70939028e5cf9401ab2fdf7cb760e58264cba260a4729128911fad6514ff15f9
+ sha256sums = 39a43abed8b8d4d385d651dcf0b15086a77755a91821eb89d462827f75c66cac
pkgname = electron-cash
diff --git a/.gitignore b/.gitignore
index 793d8b6abe6b..6b56a5ec6f78 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@
!.gitignore
!PKGBUILD
!*.install
+!*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 45e375ef6b6f..a277a95bfcb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=2.9.3
-pkgrel=2
+pkgver=2.9.4
+pkgrel=1
url='http://www.electroncash.org/'
install="${pkgname}.install"
arch=('any')
@@ -54,30 +54,42 @@ optdepends=(
)
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/fyookball/electrum/archive/${pkgver}.tar.gz")
-sha256sums=('406bc77c9a6f8a1fb69cdbe2873ad6fb2956afbb6ec0f1da71b9d6ee9f8bf8bc')
+#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/fyookball/electrum/archive/${pkgver}.tar.gz")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://electroncash.org/downloads/2.9.4/win-linux/Electron-Cash-2.9.4.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz.sig"
+)
+#https://raw.githubusercontent.com/fyookball/keys-n-hashes/master/pubkeys/jonaldkey2.txt
+validgpgkeys=('4FD06489EFF1DDE1')
+sha256sums=(
+ '70939028e5cf9401ab2fdf7cb760e58264cba260a4729128911fad6514ff15f9'
+ '39a43abed8b8d4d385d651dcf0b15086a77755a91821eb89d462827f75c66cac'
+)
build() {
- cd "${pkgname/on-cash/um}-${pkgver}"
+ #cd "${pkgname/on-cash/um}-${pkgver}"
+ cd "Electron Cash-${pkgver}"
# Compile the icons file for Qt:
python2-pyrcc5 icons.qrc -o gui/qt/icons_rc.py
- # Compile the protobuf description file:
- protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
- # Create translations (optional):
- python2 contrib/make_locale
+# # Compile the protobuf description file:
+# protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
+# # Create translations (optional):
+# python2 contrib/make_locale
# Build
python2 setup.py build
}
-check() {
- cd "${pkgname/on-cash/um}-${pkgver}"
-
- tox
-}
+#check() {
+# #cd "${pkgname/on-cash/um}-${pkgver}"
+# cd "Electron Cash-${pkgver}"
+#
+# tox2
+#}
package() {
- cd "${pkgname/on-cash/um}-${pkgver}"
+ #cd "${pkgname/on-cash/um}-${pkgver}"
+ cd "Electron Cash-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
}
diff --git a/electron-cash-2.9.4.tar.gz.sig b/electron-cash-2.9.4.tar.gz.sig
new file mode 100644
index 000000000000..c8afdbd4ca39
--- /dev/null
+++ b/electron-cash-2.9.4.tar.gz.sig
Binary files differ