summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel O'Neil2018-12-22 20:30:28 -0500
committerMarcel O'Neil2018-12-22 20:30:28 -0500
commit688c25a58f338bf7eab05d4c2e27ba161134e937 (patch)
tree596e11ec72d5148e2a36b45d97ca223dd5b78de9
parentc58997d3caf8ec8eefd350fce0370f0bef933d66 (diff)
downloadaur-688c25a58f338bf7eab05d4c2e27ba161134e937.tar.gz
3.3.3
* Added native elliptic curve cryptography using libsecp256k1 (1000x speedup on tx signing in some cases) * MacOS QR Reader now works. * Windows QR Reader now works. * Various performance fixes -- app should be able to handle much larger wallets now with many UTXOs * Nework layer fixups * Updated Checkpoint to the BCH chain. * Various minor UI gltiches fixed * MacOS binary size significantly reduced * Support for OP_RETURN parameters to bitcoincash: URL * Allow 1-of-1 multisig wallets * Server list update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e04d74526fe1..20a4a4b9bc87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electron-cash
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 3.3.2
+ pkgver = 3.3.3
pkgrel = 1
url = http://www.electroncash.org/
arch = any
@@ -34,8 +34,8 @@ pkgbase = electron-cash
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
- source = electron-cash-3.3.2.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/3.3.2.tar.gz
- sha256sums = 80999300f15233b81952e9722eb5c4659ff9d981e275bebad29baa93d125e60b
+ source = electron-cash-3.3.3.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/3.3.3.tar.gz
+ sha256sums = 587eb52e2061020b77ac3fa8a79ca3bccef280d21f93b6d8522d02c24ecaaed2
pkgname = electron-cash
diff --git a/PKGBUILD b/PKGBUILD
index 7e5e66594739..cbd2d75a8208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=3.3.2
+pkgver=3.3.3
pkgrel=1
url='http://www.electroncash.org/'
arch=('any')
@@ -47,7 +47,7 @@ optdepends=(
provides=("${pkgname}")
conflicts=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/${pkgver/.0}.tar.gz")
-sha256sums=('80999300f15233b81952e9722eb5c4659ff9d981e275bebad29baa93d125e60b')
+sha256sums=('587eb52e2061020b77ac3fa8a79ca3bccef280d21f93b6d8522d02c24ecaaed2')
build() {
cd "Electron-Cash-${pkgver/.0}"