summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-11-13 12:41:13 -0600
committerDan Beste2017-11-13 12:41:13 -0600
commit821c45af123091bee7342e26716dc77bc6b32989 (patch)
tree7dec7e83d045f19fbed0edd31d9b9afd64e3df35
parent649b700bcb7827ed8a423bab837549044785671f (diff)
downloadaur-821c45af123091bee7342e26716dc77bc6b32989.tar.gz
v2.9.4.r2
* PKGBUILD: Revert to github sources * PKGBUILD: Add python-pyqt5 & qt5-base dependencies * PKGBUILD: Add python-pyqt4 & qt4 dependencies * PKGBUILD: Fix install script not triggering
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD43
-rw-r--r--electron-cash-2.9.4.tar.gz.sigbin96 -> 0 bytes
4 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e740b8bad8f..e1b0c36d404c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-cash
pkgdesc = Lightweight Bitcoin Cash wallet
pkgver = 2.9.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.electroncash.org/
install = electron-cash.install
arch = any
@@ -19,11 +19,13 @@ pkgbase = electron-cash
depends = python2-pbkdf2
depends = python2-protobuf
depends = python2-pyaes
+ depends = python2-pyqt4
depends = python2-pyqt5
depends = python2-pysocks
depends = python2-qrcode
depends = python2-requests
depends = python2-six
+ depends = qt4
depends = qt5-base
optdepends = desktop-file-utils: update desktop icon
optdepends = gtk-update-icon-cache: update desktop icon
@@ -38,10 +40,10 @@ pkgbase = electron-cash
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
- source = electron-cash-2.9.4.tar.gz::https://electroncash.org/downloads/2.9.4/win-linux/Electron-Cash-2.9.4.tar.gz
- source = electron-cash-2.9.4.tar.gz.sig
- sha256sums = 70939028e5cf9401ab2fdf7cb760e58264cba260a4729128911fad6514ff15f9
- sha256sums = 39a43abed8b8d4d385d651dcf0b15086a77755a91821eb89d462827f75c66cac
+ source = electron-cash-2.9.4.tar.gz::https://github.com/fyookball/electrum/archive/2.9.4.tar.gz
+ source = electron-cash.install
+ sha256sums = f14c06a71ba97d1f39faa3cfcaba779f6f03ab8d44a9e3f7971d0bced3ea03b7
+ sha256sums = d682766321f9981ee38aee26dc050209882d8c1c6006e3e509649b47fa1bb073
pkgname = electron-cash
diff --git a/.gitignore b/.gitignore
index 6b56a5ec6f78..793d8b6abe6b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,4 +6,3 @@
!.gitignore
!PKGBUILD
!*.install
-!*.sig
diff --git a/PKGBUILD b/PKGBUILD
index a277a95bfcb8..cc1c9e0e9cec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
pkgver=2.9.4
-pkgrel=1
+pkgrel=2
url='http://www.electroncash.org/'
install="${pkgname}.install"
arch=('any')
@@ -32,11 +32,13 @@ depends=(
'python2-pbkdf2'
'python2-protobuf'
'python2-pyaes'
+ 'python2-pyqt4'
'python2-pyqt5'
'python2-pysocks'
'python2-qrcode'
'python2-requests'
'python2-six'
+ 'qt4'
'qt5-base'
)
optdepends=(
@@ -54,42 +56,39 @@ optdepends=(
)
provides=("${pkgname}")
conflicts=("${pkgname}")
-#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/fyookball/electrum/archive/${pkgver}.tar.gz")
+install="${pkgname}.install"
source=(
- "${pkgname}-${pkgver}.tar.gz::https://electroncash.org/downloads/2.9.4/win-linux/Electron-Cash-2.9.4.tar.gz"
- "${pkgname}-${pkgver}.tar.gz.sig"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/fyookball/electrum/archive/${pkgver}.tar.gz"
+ "${pkgname}.install"
)
-#https://raw.githubusercontent.com/fyookball/keys-n-hashes/master/pubkeys/jonaldkey2.txt
-validgpgkeys=('4FD06489EFF1DDE1')
sha256sums=(
- '70939028e5cf9401ab2fdf7cb760e58264cba260a4729128911fad6514ff15f9'
- '39a43abed8b8d4d385d651dcf0b15086a77755a91821eb89d462827f75c66cac'
+ 'f14c06a71ba97d1f39faa3cfcaba779f6f03ab8d44a9e3f7971d0bced3ea03b7'
+ 'd682766321f9981ee38aee26dc050209882d8c1c6006e3e509649b47fa1bb073'
)
build() {
- #cd "${pkgname/on-cash/um}-${pkgver}"
- cd "Electron Cash-${pkgver}"
+ cd "${pkgname/on-cash/um}-${pkgver}"
+
+ # python2-pyqt5 and qt5-base are needed for _only_ the icons...
# Compile the icons file for Qt:
python2-pyrcc5 icons.qrc -o gui/qt/icons_rc.py
-# # Compile the protobuf description file:
-# protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
-# # Create translations (optional):
-# python2 contrib/make_locale
+ # Compile the protobuf description file:
+ protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
+ # Create translations (optional):
+ python2 contrib/make_locale
# Build
python2 setup.py build
}
-#check() {
-# #cd "${pkgname/on-cash/um}-${pkgver}"
-# cd "Electron Cash-${pkgver}"
-#
-# tox2
-#}
+check() {
+ cd "${pkgname/on-cash/um}-${pkgver}"
+
+ tox2
+}
package() {
- #cd "${pkgname/on-cash/um}-${pkgver}"
- cd "Electron Cash-${pkgver}"
+ cd "${pkgname/on-cash/um}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
}
diff --git a/electron-cash-2.9.4.tar.gz.sig b/electron-cash-2.9.4.tar.gz.sig
deleted file mode 100644
index c8afdbd4ca39..000000000000
--- a/electron-cash-2.9.4.tar.gz.sig
+++ /dev/null
Binary files differ