summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Tran2020-10-22 00:02:57 -0500
committerMatthew Tran2020-10-22 00:02:57 -0500
commitd802382ee07d44b5b36762c3f1ca2d5fedad2073 (patch)
treeae346c80249a4651c34799af43d5326df2fe7b97
parent05f5576cb81afa597e80ac04d788f52dfac3fac4 (diff)
downloadaur-d802382ee07d44b5b36762c3f1ca2d5fedad2073.tar.gz
4.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 967db146dd18..01ee3b102f82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-cash
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 4.1.1
- pkgrel = 6
+ pkgver = 4.2.0
+ pkgrel = 1
url = http://www.electroncash.org/
arch = any
license = MIT
@@ -42,9 +42,9 @@ pkgbase = electron-cash
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
- source = electron-cash-4.1.1.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/4.1.1.tar.gz
+ source = electron-cash-4.2.0.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/4.2.0.tar.gz
source = secp256k1-0.20.9.tar.gz::https://github.com/Bitcoin-ABC/secp256k1/archive/v0.20.9.tar.gz
- sha256sums = 06acc6290c19a74d2a8cfb962f38e5fc260c9a76aeb14a4d15bfa288eb69fdaf
+ sha256sums = 7bb1b227f206b8a237f9f99dd20513b6c60e5af19cc280a5068536502fb30aab
sha256sums = 68e84775e57da77e19ccb6b0dde6ca0882377bdd48ecc6da0047a70201ec64c8
pkgname = electron-cash
diff --git a/PKGBUILD b/PKGBUILD
index 9fba982cb7f0..008d7bf1f5e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=4.1.1
+pkgver=4.2.0
secp256k1ver=0.20.9
-pkgrel=6
+pkgrel=1
url='http://www.electroncash.org/'
arch=('any')
license=('MIT')
@@ -58,7 +58,7 @@ provides=("${pkgname}")
conflicts=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/${pkgver}.tar.gz"
"secp256k1-${secp256k1ver}.tar.gz::https://github.com/Bitcoin-ABC/secp256k1/archive/v${secp256k1ver}.tar.gz")
-sha256sums=('06acc6290c19a74d2a8cfb962f38e5fc260c9a76aeb14a4d15bfa288eb69fdaf'
+sha256sums=('7bb1b227f206b8a237f9f99dd20513b6c60e5af19cc280a5068536502fb30aab'
'68e84775e57da77e19ccb6b0dde6ca0882377bdd48ecc6da0047a70201ec64c8')
prepare() {
@@ -74,9 +74,9 @@ build() {
# python2-pyqt5 and qt5-base are needed for _only_ the icons...
# Compile the icons file for Qt:
- pyrcc5 icons.qrc -o gui/qt/icons_rc.py
+ pyrcc5 icons.qrc -o electroncash_gui/qt/icons_rc.py
# Compile the protobuf description file:
- protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
+ protoc --proto_path=electroncash/ --python_out=electroncash/ electroncash/paymentrequest.proto
# Create translations (optional):
python contrib/make_locale
# Use libsecp