summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel O'Neil2019-03-28 09:36:40 -0400
committerMarcel O'Neil2019-03-28 09:36:40 -0400
commit491a6db61438aabba85dde1c1a32f8646e26e558 (patch)
treee15eb91ef3e42d0a4af67a62c61b87c3953ab77d
parentfec373db14c52886e674b17035cbce37aeb44c42 (diff)
downloadaur-491a6db61438aabba85dde1c1a32f8646e26e558.tar.gz
remove patch, merged
-rw-r--r--.SRCINFO4
-rw-r--r--0001-setup.py-option-to-disable-secp-build.patch58
-rw-r--r--PKGBUILD14
3 files changed, 4 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c3001b2a96e..d8523c9d3e46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electron-cash-git
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 4.0.0.r4.g8f37431dc
+ pkgver = 4.0.0.r5.g5ebf46a60
pkgrel = 1
url = http://www.electroncash.org/
arch = any
@@ -34,9 +34,7 @@ pkgbase = electron-cash-git
provides = electron-cash
conflicts = electron-cash
source = electron-cash-git::git+https://github.com/Electron-Cash/Electron-Cash.git
- source = 0001-setup.py-option-to-disable-secp-build.patch
sha256sums = SKIP
- sha256sums = 3a201d65a364a1f6290c19269f7e4cd79f08af86da851a93d1b0e9d5e79d2d3c
pkgname = electron-cash-git
diff --git a/0001-setup.py-option-to-disable-secp-build.patch b/0001-setup.py-option-to-disable-secp-build.patch
deleted file mode 100644
index 6920ed325680..000000000000
--- a/0001-setup.py-option-to-disable-secp-build.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 90bf467b564389ea93b1cb60d9971e9ddbbc0a16 Mon Sep 17 00:00:00 2001
-From: Marcel O'Neil <marcel@marceloneil.com>
-Date: Wed, 27 Mar 2019 22:45:05 -0400
-Subject: [PATCH] setup.py: option to disable secp build
-
----
- setup.py | 34 ++++++++++++++++++++++++----------
- 1 file changed, 24 insertions(+), 10 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 2affc297..8b3fff86 100755
---- a/setup.py
-+++ b/setup.py
-@@ -62,17 +62,31 @@ if platform.system() in ['Linux', 'FreeBSD', 'DragonFly']:
- ]
-
- class MakeAllBeforeSdist(setuptools.command.sdist.sdist):
-- """Does some custom stuff before calling super().run()."""
-+ """Does some custom stuff before calling super().run()."""
-
-- def run(self):
-- """Run command."""
-- #self.announce("Running make_locale...")
-- #0==os.system("contrib/make_locale") or sys.exit("Could not make locale, aborting")
-- #self.announce("Running make_packages...")
-- #0==os.system("contrib/make_packages") or sys.exit("Could not make locale, aborting")
-- self.announce("Running make_secp...")
-- 0==os.system("contrib/make_secp") or sys.exit("Could not build libsecp256k1")
-- super().run()
-+ user_options = setuptools.command.sdist.sdist.user_options + [
-+ ("disable-secp", None, "Disable libsecp256k1 complilation.")
-+ ]
-+
-+ def initialize_options(self):
-+ self.disable_secp = None
-+ super().initialize_options()
-+
-+ def finalize_options(self):
-+ if self.disable_secp is None:
-+ self.disable_secp = False # Default to build secp
-+ super().finalize_options()
-+
-+ def run(self):
-+ """Run command."""
-+ #self.announce("Running make_locale...")
-+ #0==os.system("contrib/make_locale") or sys.exit("Could not make locale, aborting")
-+ #self.announce("Running make_packages...")
-+ #0==os.system("contrib/make_packages") or sys.exit("Could not make locale, aborting")
-+ if not self.disable_secp:
-+ self.announce("Running make_secp...")
-+ 0==os.system("contrib/make_secp") or sys.exit("Could not build libsecp256k1")
-+ super().run()
-
- setup(
- cmdclass={
---
-2.21.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 7dbf882517ef..b6b683bb5ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='electron-cash-git'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=4.0.0.r4.g8f37431dc
+pkgver=4.0.0.r5.g5ebf46a60
pkgrel=1
url='http://www.electroncash.org/'
arch=('any')
@@ -45,16 +45,8 @@ optdepends=(
)
provides=("${pkgname/-git/}")
conflicts=("${pkgname/-git/}")
-source=("${pkgname}::git+https://github.com/Electron-Cash/Electron-Cash.git"
- "0001-setup.py-option-to-disable-secp-build.patch")
-sha256sums=('SKIP'
- '3a201d65a364a1f6290c19269f7e4cd79f08af86da851a93d1b0e9d5e79d2d3c')
-
-prepare() {
- cd "${pkgname}"
-
- patch -Np1 -i "${srcdir}/0001-setup.py-option-to-disable-secp-build.patch"
-}
+source=("${pkgname}::git+https://github.com/Electron-Cash/Electron-Cash.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"