summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Tran2020-01-21 07:39:21 -0600
committerMatthew Tran2020-01-21 07:39:21 -0600
commita30475f6f6efe87f3e319cd235e428301979a39c (patch)
tree0e17dc3eac5c41bd1af883557dd74ec7f7d66a16
parentdd905c13eb785502f4c07f8ebc042d1df6bc958a (diff)
downloadaur-a30475f6f6efe87f3e319cd235e428301979a39c.tar.gz
Add tox.ini patch and python-stem dependency
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
-rw-r--r--tox.ini.patch10
4 files changed, 32 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b6d68de9dad..5fe7c765e53b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electron-cash-git
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 4.0.11.r3.g7f761fb0f
+ pkgver = 4.0.13.dev1.r19.ge16d90887
pkgrel = 1
url = http://www.electroncash.org/
arch = any
@@ -24,6 +24,7 @@ pkgbase = electron-cash-git
depends = python-qrcode
depends = python-requests
depends = python-six
+ depends = python-stem
depends = qt5-base
depends = qt5-svg
depends = ttf-bitstream-vera
@@ -33,11 +34,15 @@ pkgbase = electron-cash-git
optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
optdepends = python-qdarkstyle: optional dark theme in graphical mode
optdepends = python-rpyc: send commands to Electrum Python console from an external script
+ optdepends = python-trezor: Trezor hardware wallet support
+ optdepends = python-keepkey: Trezor hardware wallet support
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
source = electron-cash-git::git+https://github.com/Electron-Cash/Electron-Cash.git
+ source = tox.ini.patch
sha256sums = SKIP
+ sha256sums = 39c85a1eec8fcdc7fa80d47ff464e023b092cc623dce7fd6f42abe547c017ecb
pkgname = electron-cash-git
diff --git a/.gitignore b/.gitignore
index 793d8b6abe6b..9ea04f23e1b6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@
!.gitignore
!PKGBUILD
!*.install
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9c86a86403ed..78f01709e134 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='electron-cash-git'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=4.0.11.r3.g7f761fb0f
+pkgver=4.0.13.dev1.r19.ge16d90887
pkgrel=1
url='http://www.electroncash.org/'
arch=('any')
@@ -33,6 +33,7 @@ depends=(
'python-qrcode'
'python-requests'
'python-six'
+ 'python-stem'
'qt5-base'
'qt5-svg'
'ttf-bitstream-vera'
@@ -44,12 +45,23 @@ optdepends=(
'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
'python-qdarkstyle: optional dark theme in graphical mode'
'python-rpyc: send commands to Electrum Python console from an external script'
+ 'python-trezor: Trezor hardware wallet support'
+ 'python-keepkey: Trezor hardware wallet support'
'zbar: QR code reading support'
)
provides=("${pkgname/-git/}")
conflicts=("${pkgname/-git/}")
-source=("${pkgname}::git+https://github.com/Electron-Cash/Electron-Cash.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/Electron-Cash/Electron-Cash.git"
+ "tox.ini.patch")
+sha256sums=('SKIP'
+ '39c85a1eec8fcdc7fa80d47ff464e023b092cc623dce7fd6f42abe547c017ecb')
+
+prepare() {
+ cd "${pkgname}"
+
+ # Patch tox.ini to use the latest pip
+ patch --forward --strip=1 --input="${srcdir}/tox.ini.patch"
+}
pkgver() {
cd "${pkgname}"
diff --git a/tox.ini.patch b/tox.ini.patch
new file mode 100644
index 000000000000..4adefc91f1ba
--- /dev/null
+++ b/tox.ini.patch
@@ -0,0 +1,10 @@
+--- src/tox.ini 2020-01-21 06:56:13.435221362 -0600
++++ src/tox.ini 2020-01-21 06:56:32.611884531 -0600
+@@ -3,6 +3,7 @@
+
+ [testenv]
+ deps=
++ pip>=19
+ pytest
+ coverage
+ pycryptodomex<3.7