summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel O'Neil2019-03-27 23:23:12 -0400
committerMarcel O'Neil2019-03-27 23:23:12 -0400
commitfec373db14c52886e674b17035cbce37aeb44c42 (patch)
treed2e90a73c0c456a4d6c1c42977c0d6b33ddd507e
parent97264cec8d934f3c54d5f925d4e07a0deaa36188 (diff)
downloadaur-fec373db14c52886e674b17035cbce37aeb44c42.tar.gz
4.0.0 w/ PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5002f53c0064..3c3001b2a96e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electron-cash-git
pkgdesc = Lightweight Bitcoin Cash wallet
- pkgver = 3.3.6.r1.gaf3482651
+ pkgver = 4.0.0.r4.g8f37431dc
pkgrel = 1
url = http://www.electroncash.org/
arch = any
@@ -11,6 +11,7 @@ pkgbase = electron-cash-git
makedepends = python-setuptools
makedepends = python-tox
depends = hicolor-icon-theme
+ depends = libsecp256k1
depends = python
depends = python-dnspython
depends = python-ecdsa
@@ -23,19 +24,19 @@ pkgbase = electron-cash-git
depends = python-requests
depends = python-six
depends = qt5-base
- optdepends = desktop-file-utils: update desktop icon
- optdepends = gtk-update-icon-cache: update desktop icon
optdepends = python-btchip: Ledger hardware wallet support
optdepends = python-hidapi: Digital Bitbox hardware wallet support
- optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
optdepends = python-matplotlib: plot transaction history in graphical mode
+ optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
+ optdepends = python-qdarkstyle: optional dark theme in graphical mode
optdepends = python-rpyc: send commands to Electrum Python console from an external script
- optdepends = xdg-utils: update desktop icon
optdepends = zbar: QR code reading support
provides = electron-cash
conflicts = electron-cash
source = electron-cash-git::git+https://github.com/Electron-Cash/Electron-Cash.git
+ source = 0001-setup.py-option-to-disable-secp-build.patch
sha256sums = SKIP
+ sha256sums = 3a201d65a364a1f6290c19269f7e4cd79f08af86da851a93d1b0e9d5e79d2d3c
pkgname = electron-cash-git
diff --git a/PKGBUILD b/PKGBUILD
index b667f40ac776..7dbf882517ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='electron-cash-git'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=3.3.6.r1.gaf3482651
+pkgver=4.0.0.r4.g8f37431dc
pkgrel=1
url='http://www.electroncash.org/'
arch=('any')
@@ -20,6 +20,7 @@ makedepends=(
)
depends=(
'hicolor-icon-theme'
+ 'libsecp256k1'
'python'
'python-dnspython'
'python-ecdsa'
@@ -34,20 +35,26 @@ depends=(
'qt5-base'
)
optdepends=(
- 'desktop-file-utils: update desktop icon'
- 'gtk-update-icon-cache: update desktop icon'
'python-btchip: Ledger hardware wallet support'
'python-hidapi: Digital Bitbox hardware wallet support'
- 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
'python-matplotlib: plot transaction history in graphical mode'
+ 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
+ 'python-qdarkstyle: optional dark theme in graphical mode'
'python-rpyc: send commands to Electrum Python console from an external script'
- 'xdg-utils: update desktop icon'
'zbar: QR code reading support'
)
provides=("${pkgname/-git/}")
conflicts=("${pkgname/-git/}")
-source=("${pkgname}::git+https://github.com/Electron-Cash/Electron-Cash.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/Electron-Cash/Electron-Cash.git"
+ "0001-setup.py-option-to-disable-secp-build.patch")
+sha256sums=('SKIP'
+ '3a201d65a364a1f6290c19269f7e4cd79f08af86da851a93d1b0e9d5e79d2d3c')
+
+prepare() {
+ cd "${pkgname}"
+
+ patch -Np1 -i "${srcdir}/0001-setup.py-option-to-disable-secp-build.patch"
+}
pkgver() {
cd "${pkgname}"
@@ -72,7 +79,8 @@ build() {
check() {
cd "${pkgname}"
- tox -e py37
+ python setup.py sdist --format=gztar --disable-secp
+ tox -e py37 --installpkg "dist/Electron Cash-${pkgver/.r*}.tar.gz"
}
package() {