summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-04-18 01:23:37 +1000
committerDaniel Playfair Cal2020-04-18 01:23:37 +1000
commit96b5797835b82d9267e5d0422122029552975d46 (patch)
treee28d9df16aef0e82b1cffa4d0b14136f3f08e216
parent4c6ba7d10c93586bec29f142fdad53d5aa0e7972 (diff)
downloadaur-96b5797835b82d9267e5d0422122029552975d46.tar.gz
Don't strip binary in debugs builds
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf004fb6c16..9e6643a8ac9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-ozone
pkgdesc = Electron compiled with wayland support via Ozone
pkgver = 8.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://electronjs.org/
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 9195af474480..57262b245052 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ provides=('electron')
conflicts=('electron')
_commit=663d389925a9637609c07f1212edeca337f591be
_chromiumver=80.0.3987.163
-pkgrel=1
+pkgrel=2
pkgdesc='Electron compiled with wayland support via Ozone'
arch=('x86_64')
options=(debug !strip)
@@ -238,7 +238,9 @@ build() {
ninja -C out/Release electron
# Strip before zip to avoid
# zipfile.LargeZipFile: Filesize would require ZIP64 extensions
- strip -s out/Release/electron
+ if check_option strip y; then
+ strip -s out/Release/electron
+ fi
ninja -C out/Release electron_dist_zip
# ninja -C out/Release third_party/electron_node:headers
}