summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-01-13 13:11:23 +1100
committerDaniel Playfair Cal2020-01-13 13:11:23 +1100
commitdae2819c760804ed7a76b340da5408679f027d90 (patch)
tree68a14617a912c8b3aaf22d376b636312420c1365
parent62212cfe6d9b607b549dce8ee66710966fccb8ad (diff)
downloadaur-dae2819c760804ed7a76b340da5408679f027d90.tar.gz
use bundled clang, set debug flags by default
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55e2d824b4d6..d66225d1c46a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron-ozone
pkgdesc = Electron compiled with wayland support via Ozone
pkgver = 7.1.8
- pkgrel = 1
+ pkgrel = 2
url = https://electronjs.org/
arch = x86_64
license = MIT
@@ -41,6 +41,8 @@ pkgbase = electron-ozone
optdepends = xdg-utils: open URLs with desktop's default (xdg-email, xdg-open)
provides = electron
conflicts = electron
+ options = debug
+ options = !strip
source = git+https://github.com/hedgepigdaniel/electron.git#branch=arch7.1.8-1
source = git+https://chromium.googlesource.com/chromium/tools/depot_tools.git
source = electron.desktop
diff --git a/PKGBUILD b/PKGBUILD
index a1a2bae61659..d3668cf49c7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,10 @@ provides=('electron')
conflicts=('electron')
_commit=30a94ac944127293d3fd54ede2e3882a871ea8ec
_chromiumver=78.0.3904.130
-pkgrel=1
+pkgrel=2
pkgdesc='Electron compiled with wayland support via Ozone'
arch=('x86_64')
+options=(debug !strip)
url='https://electronjs.org/'
license=('MIT' 'custom')
depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libnghttp2'
@@ -94,6 +95,7 @@ prepare() {
echo "Running hooks..."
# python2 "${srcdir}/depot_tools/gclient.py" runhooks
+ python2 src/tools/clang/scripts/update.py
python2 src/build/landmines.py
python2 src/build/util/lastchange.py -o src/build/util/LASTCHANGE
python2 src/build/util/lastchange.py -m GPU_LISTS_VERSION \
@@ -146,22 +148,10 @@ prepare() {
}
build() {
- export CC=clang
- export CXX=clang++
- export AR=ar
- export NM=nm
-
- # Do not warn about unknown warning options
- CFLAGS+=' -Wno-unknown-warning-option'
- CXXFLAGS+=' -Wno-unknown-warning-option'
-
cd src
export CHROMIUM_BUILDTOOLS_PATH="${PWD}/buildtools"
local _flags=(
'blink_symbol_level = 0'
- 'clang_use_chrome_plugins = false'
- 'custom_toolchain = "//build/toolchain/linux/unbundle:default"'
- 'host_toolchain = "//build/toolchain/linux/unbundle:default"'
'icu_use_data_file = false'
'is_component_ffmpeg = false'
'link_pulseaudio = true'