summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-13 17:04:24 +0800
committerzxp198210052023-10-13 17:04:24 +0800
commit1d3ce667b07f6696ab059ad30be4ffb88cc2e4f3 (patch)
tree3cce669d5ca55132778acb3bd9ba1b94b3baffe7
parent177ceee29b1d99a19d41cc18d425b7e417b66b73 (diff)
downloadaur-1d3ce667b07f6696ab059ad30be4ffb88cc2e4f3.tar.gz
fix errors
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def80c1c3c6f..f0385343639c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = electron-s3-file-manager
pkgdesc = A GUI AWS S3 file manager. It supports keyword search, download, upload and preview video.
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kelp404/electron-s3-file-manager
arch = any
license = MIT
makedepends = gendesk
makedepends = npm
+ makedepends = nodejs>=18
depends = bash
depends = make
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index fb7154a4629c..7cbb4aacf551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=electron-s3-file-manager
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A GUI AWS S3 file manager. It supports keyword search, download, upload and preview video."
arch=('any')
url="https://github.com/kelp404/electron-s3-file-manager"
@@ -9,21 +9,22 @@ license=('MIT')
conflicts=("${pkgname}")
depends=('bash' 'make' 'python' 'alsa-lib' 'libdrm' 'pango' 'nss' 'gtk3' 'libxfixes' 'libxdamage' 'gcc-libs' 'glib2' 'cairo' 'nspr' \
'libxcomposite' 'libcups' 'dbus' 'libx11' 'glibc' 'at-spi2-core' 'libxrandr' 'libxkbcommon' 'expat' 'mesa' 'libxext' 'libxcb' 'wayland')
-makedepends=('gendesk' 'npm')
+makedepends=('gendesk' 'npm' 'nodejs>=18')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('482233095b915bcca18e7b1729a3f9145e76c378d2099110585e3c7cccec156d')
+prepare() {
+ gendesk -f -n -q --categories "Utility" --name "${pkgname}" --exec "${pkgname} --no-sandbox %U"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -e '/dmg/d' -e "s|win|linux|g" -e "s|portable|AppImage|g" -i tools.js
npm install
- sed '59d' -i tools.js
- sed "s|win|linux|g;s|portable|AppImage|g" -i tools.js
npm run build
}
package() {
- install -Dm755 -d "${pkgdir}/opt/${pkgname}" "${pkgdir}/usr/bin"
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname}",usr/bin}
cp -r "${srcdir}/${pkgname}-${pkgver}/dist/linux-unpacked/"* "${pkgdir}/opt/${pkgname}"
ln -sf "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- gendesk -f -n --categories "Utility" --name "${pkgname}" --exec "${pkgname}"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file