summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-05-09 09:03:30 +0800
committerzxp198210052024-05-09 09:03:30 +0800
commitc08c225beebc3a003373d1d47193c9f2445f8339 (patch)
treea648b39f7d8b7a12b4bff16941fd81f63fff9dfd
parent1eb1cddbc590991de8ea92fe54c1bf4c98e95023 (diff)
downloadaur-c08c225beebc3a003373d1d47193c9f2445f8339.tar.gz
update to 2.0.4.r0.gf61f63e
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--electron-widgets.sh14
3 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6823d420eaf5..5aa55df9d843 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electron-widgets-git
pkgdesc = A desktop application developed using Electron.js and Node.js. The application allows users to create and manage widgets on their desktops.
- pkgver = 2.0.3.r0.gbccec92
+ pkgver = 2.0.4.r0.gf61f63e
pkgrel = 1
url = https://electron-widgets.vercel.app/
arch = any
@@ -9,12 +9,13 @@ pkgbase = electron-widgets-git
makedepends = git
makedepends = nvm
makedepends = gendesk
+ makedepends = curl
depends = electron30
- provides = electron-widgets=2.0.3
+ provides = electron-widgets=2.0.4
conflicts = electron-widgets
source = electron-widgets.git::git+https://github.com/sametcn99/electron-widgets.git
source = electron-widgets.sh
sha256sums = SKIP
- sha256sums = 61d56055897e9d71d68e185ac2de7c4cb2fbca16eb3fb0091703612c113441f3
+ sha256sums = 05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a
pkgname = electron-widgets-git
diff --git a/PKGBUILD b/PKGBUILD
index 4d420e17680f..b9ae3da22f9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=electron-widgets-git
_pkgname="Electron-Widgets"
-pkgver=2.0.3.r0.gbccec92
+pkgver=2.0.4.r0.gf61f63e
_electronversion=30
_nodeversion=20
pkgrel=1
@@ -20,12 +20,13 @@ makedepends=(
'git'
'nvm'
'gendesk'
+ 'curl'
)
source=(
"${pkgname%-git}.git::git+${_ghurl}.git"
"${pkgname%-git}.sh")
sha256sums=('SKIP'
- '61d56055897e9d71d68e185ac2de7c4cb2fbca16eb3fb0091703612c113441f3')
+ '05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a')
pkgver() {
cd "${srcdir}/${pkgname%-git}.git"
git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
@@ -51,9 +52,9 @@ build() {
export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
export ELECTRONVERSION="${_electronversion}"
- export npm_config_disturl=https://registry.npmmirror.com/-/binary/node/
HOME="${srcdir}/.electron-gyp"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
+ export npm_config_disturl=https://registry.npmmirror.com/-/binary/node/
export npm_config_registry=https://registry.npmmirror.com
export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
diff --git a/electron-widgets.sh b/electron-widgets.sh
index 842c77e19b1d..5594e5380ba2 100644
--- a/electron-widgets.sh
+++ b/electron-widgets.sh
@@ -7,14 +7,22 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
export NODE_ENV=production
export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
-if [ -r "${_FLAGS_FILE}" ]; then
- _USER_FLAGS="$(cat "${_FLAGS_FILE}")"
+declare -a flags
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ mapfile -t < "${_FLAGS_FILE}"
fi
+for line in "${MAPFILE[@]}"; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]] && [[ -n "${line}" ]]; then
+ flags+=("${line}")
+ fi
+done
cd "${_APPDIR}"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?