summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoutrelis2021-09-18 12:38:10 +0000
committersvntogit2021-09-18 12:38:10 +0000
commitc11404aa053e860ba865da21035ccf70c89dbe78 (patch)
tree8042a0ed7b2a7cc24c436821fbc30cf05ca9c155
parentd1fe9922d136f0ddb622877304db37cf5397d28b (diff)
downloadaur-c11404aa053e860ba865da21035ccf70c89dbe78.tar.gz
upgpkg: electron13 13.4.0-2: harfbuzz 3.0.0 rebuild
git-svn-id: file:///srv/repos/svn-community/svn@1016925 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--chromium-harfbuzz-3.0.0.patch20
-rw-r--r--skia-harfbuzz-3.0.0.patch100
4 files changed, 132 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d8585d73d96..701e432d7330 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electron13
pkgdesc = Build cross platform desktop apps with web technologies
pkgver = 13.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://electronjs.org/
arch = x86_64
license = MIT
@@ -49,6 +49,8 @@ pkgbase = electron13
source = add-clang-nomerge-attribute-to-CheckError.patch
source = chromium-freetype-2.11.patch
source = chromium-glibc-2.33.patch
+ source = chromium-harfbuzz-3.0.0.patch
+ source = skia-harfbuzz-3.0.0.patch
source = sql-make-VirtualCursor-standard-layout-type.patch
source = unbundle-use-char16_t-as-UCHAR_TYPE.patch
sha256sums = SKIP
@@ -61,6 +63,8 @@ pkgbase = electron13
sha256sums = 50133dd196d288ad538bb536aa51dccd6cb4aacfd9a60160f77e8fb16034b460
sha256sums = 940346d3599d09366068d88b65dfcbcab187ceb5d14dc7c7f9b6ae5e6f25ec7d
sha256sums = 2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b
+ sha256sums = 7ce947944a139e66774dfc7249bf7c3069f07f83a0f1b2c1a1b14287a7e15928
+ sha256sums = c9ed1dbadaf4be6097e25bc5577b91751799befc2d0376b143e1bd10def5754e
sha256sums = dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150
sha256sums = 59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d
diff --git a/PKGBUILD b/PKGBUILD
index defb3444e2d5..5657087cf6ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=13.4.0
_commit=75f366f4d0be2318584ffd3157b0e7356fce7c78
_chromiumver=91.0.4472.164
_gcc_patchset=5
-pkgrel=1
+pkgrel=2
pkgdesc='Build cross platform desktop apps with web technologies'
arch=('x86_64')
url='https://electronjs.org/'
@@ -30,6 +30,8 @@ source=('git+https://github.com/electron/electron.git'
'add-clang-nomerge-attribute-to-CheckError.patch'
'chromium-freetype-2.11.patch'
'chromium-glibc-2.33.patch'
+ 'chromium-harfbuzz-3.0.0.patch'
+ 'skia-harfbuzz-3.0.0.patch'
'sql-make-VirtualCursor-standard-layout-type.patch'
'unbundle-use-char16_t-as-UCHAR_TYPE.patch'
)
@@ -43,6 +45,8 @@ sha256sums=('SKIP'
'50133dd196d288ad538bb536aa51dccd6cb4aacfd9a60160f77e8fb16034b460'
'940346d3599d09366068d88b65dfcbcab187ceb5d14dc7c7f9b6ae5e6f25ec7d'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
+ '7ce947944a139e66774dfc7249bf7c3069f07f83a0f1b2c1a1b14287a7e15928'
+ 'c9ed1dbadaf4be6097e25bc5577b91751799befc2d0376b143e1bd10def5754e'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d'
)
@@ -138,6 +142,8 @@ prepare() {
patch -Rp1 -i ../add-clang-nomerge-attribute-to-CheckError.patch
patch -Np1 -i ../chromium-freetype-2.11.patch
patch -Np1 -i ../chromium-glibc-2.33.patch
+ patch -Np1 -i ../chromium-harfbuzz-3.0.0.patch
+ patch -Np1 -d third_party/skia <../skia-harfbuzz-3.0.0.patch
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
patch -Np1 -i ../unbundle-use-char16_t-as-UCHAR_TYPE.patch
patch -Np1 -i ../use-system-libraries-in-node.patch
diff --git a/chromium-harfbuzz-3.0.0.patch b/chromium-harfbuzz-3.0.0.patch
new file mode 100644
index 000000000000..c7724336bfba
--- /dev/null
+++ b/chromium-harfbuzz-3.0.0.patch
@@ -0,0 +1,20 @@
+# https://github.com/chromium/chromium/commit/b289f6f3fcbc
+
+diff --git a/components/paint_preview/common/subset_font.cc b/components/paint_preview/common/subset_font.cc
+index 8ff0540d9a..20a7d37474 100644
+--- a/components/paint_preview/common/subset_font.cc
++++ b/components/paint_preview/common/subset_font.cc
+@@ -72,9 +72,11 @@ sk_sp<SkData> SubsetFont(SkTypeface* typeface, const GlyphUsage& usage) {
+ hb_set_t* glyphs =
+ hb_subset_input_glyph_set(input.get()); // Owned by |input|.
+ usage.ForEach(base::BindRepeating(&AddGlyphs, base::Unretained(glyphs)));
+- hb_subset_input_set_retain_gids(input.get(), true);
++ hb_subset_input_set_flags(input.get(), HB_SUBSET_FLAGS_RETAIN_GIDS);
+
+- HbScoped<hb_face_t> subset_face(hb_subset(face.get(), input.get()));
++ HbScoped<hb_face_t> subset_face(hb_subset_or_fail(face.get(), input.get()));
++ if (!subset_face)
++ return nullptr;
+ HbScoped<hb_blob_t> subset_blob(hb_face_reference_blob(subset_face.get()));
+ if (!subset_blob)
+ return nullptr;
diff --git a/skia-harfbuzz-3.0.0.patch b/skia-harfbuzz-3.0.0.patch
new file mode 100644
index 000000000000..859cc90215cf
--- /dev/null
+++ b/skia-harfbuzz-3.0.0.patch
@@ -0,0 +1,100 @@
+# Minimal diff for harfbuzz 3.0.0 support; based on:
+# https://github.com/google/skia/commit/66684b17b382
+# https://github.com/google/skia/commit/51d83abcd24a
+
+diff --git a/gn/skia.gni b/gn/skia.gni
+index d98fdc19ee..199335d5c4 100644
+--- a/gn/skia.gni
++++ b/gn/skia.gni
+@@ -34,8 +34,6 @@ declare_args() {
+ skia_include_multiframe_procs = false
+ skia_lex = false
+ skia_libgifcodec_path = "third_party/externals/libgifcodec"
+- skia_pdf_subset_harfbuzz =
+- false # TODO: set skia_pdf_subset_harfbuzz to skia_use_harfbuzz.
+ skia_qt_path = getenv("QT_PATH")
+ skia_skqp_global_error_tolerance = 0
+ skia_tools_require_resources = false
+@@ -99,6 +97,10 @@ declare_args() {
+ skia_use_libfuzzer_defaults = true
+ }
+
++declare_args() {
++ skia_pdf_subset_harfbuzz = skia_use_harfbuzz
++}
++
+ declare_args() {
+ skia_compile_sksl_tests = skia_compile_processors
+ skia_enable_fontmgr_android = skia_use_expat && skia_use_freetype
+diff --git a/src/pdf/SkPDFSubsetFont.cpp b/src/pdf/SkPDFSubsetFont.cpp
+index 81c37eef3a..2340a7937b 100644
+--- a/src/pdf/SkPDFSubsetFont.cpp
++++ b/src/pdf/SkPDFSubsetFont.cpp
+@@ -49,6 +49,37 @@ static sk_sp<SkData> to_data(HBBlob blob) {
+ blob.release());
+ }
+
++template<typename...> using void_t = void;
++template<typename T, typename = void>
++struct SkPDFHarfBuzzSubset {
++ // This is the HarfBuzz 3.0 interface.
++ // hb_subset_flags_t does not exist in 2.0. It isn't dependent on T, so inline the value of
++ // HB_SUBSET_FLAGS_RETAIN_GIDS until 2.0 is no longer supported.
++ static HBFace Make(T input, hb_face_t* face) {
++ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
++ // If it isn't known if a font is 'tricky', retain the hints.
++ hb_subset_input_set_flags(input, 2/*HB_SUBSET_FLAGS_RETAIN_GIDS*/);
++ return HBFace(hb_subset_or_fail(face, input));
++ }
++};
++template<typename T>
++struct SkPDFHarfBuzzSubset<T, void_t<
++ decltype(hb_subset_input_set_retain_gids(std::declval<T>(), std::declval<bool>())),
++ decltype(hb_subset_input_set_drop_hints(std::declval<T>(), std::declval<bool>())),
++ decltype(hb_subset(std::declval<hb_face_t*>(), std::declval<T>()))
++ >>
++{
++ // This is the HarfBuzz 2.0 (non-public) interface, used if it exists.
++ // This code should be removed as soon as all users are migrated to the newer API.
++ static HBFace Make(T input, hb_face_t* face) {
++ hb_subset_input_set_retain_gids(input, true);
++ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
++ // If it isn't known if a font is 'tricky', retain the hints.
++ hb_subset_input_set_drop_hints(input, false);
++ return HBFace(hb_subset(face, input));
++ }
++};
++
+ static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
+ const SkPDFGlyphUse& glyphUsage,
+ int ttcIndex) {
+@@ -71,11 +102,10 @@ static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
+ hb_set_t* glyphs = hb_subset_input_glyph_set(input.get());
+ glyphUsage.getSetValues([&glyphs](unsigned gid) { hb_set_add(glyphs, gid);});
+
+- hb_subset_input_set_retain_gids(input.get(), true);
+- // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
+- // If it isn't known if a font is 'tricky', retain the hints.
+- hb_subset_input_set_drop_hints(input.get(), false);
+- HBFace subset(hb_subset(face.get(), input.get()));
++ HBFace subset = SkPDFHarfBuzzSubset<hb_subset_input_t*>::Make(input.get(), face.get());
++ if (!subset) {
++ return nullptr;
++ }
+ HBBlob result(hb_face_reference_blob(subset.get()));
+ return to_data(std::move(result));
+ }
+diff --git a/third_party/harfbuzz/BUILD.gn b/third_party/harfbuzz/BUILD.gn
+index 173830de62..4156607ef9 100644
+--- a/third_party/harfbuzz/BUILD.gn
++++ b/third_party/harfbuzz/BUILD.gn
+@@ -14,6 +14,9 @@ if (skia_use_system_harfbuzz) {
+ "harfbuzz",
+ "harfbuzz-icu",
+ ]
++ if (skia_pdf_subset_harfbuzz) {
++ libs += [ "harfbuzz-subset" ]
++ }
+ }
+ } else {
+ third_party("harfbuzz") {