summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:01:50 +0100
committerDaniel Peukert2024-01-28 00:01:50 +0100
commitfb7d18dc75e3e4ffd6ca2f0e8c458513fed0a8a3 (patch)
treede7263c46289e084a311a7b851436b3ab9ad958e
parent5295f25cb60e9eb4fdd8899c4a3af1252d48e0de (diff)
downloadaur-fb7d18dc75e3e4ffd6ca2f0e8c458513fed0a8a3.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
2 files changed, 16 insertions, 17 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 41da4ddde6de..819e5fc48050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,7 +67,6 @@ package() {
install -Dm755 'electron-launcher.sh' "$pkgdir/usr/bin/$_pkgname"
- for _license in 'LICENSE' 'LICENSES.chromium.html'; do
- install -Dm644 "$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
- done
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/MIT"
+ install -Dm644 'LICENSES.chromium.html' "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
}