summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoutrelis2020-04-29 09:12:02 +0000
committerMartin Kröning2020-06-12 10:10:37 +0200
commit0e21505888352076adebd6e8a23a92cbf2e5dada (patch)
treefea522ecdde7cfb595ddf6797863188d37717857
parent0d4a597ffa509d4b3e669566af6e6e9b5720b45d (diff)
downloadaur-0e21505888352076adebd6e8a23a92cbf2e5dada.tar.gz
Fix build with clang 10; add workaround for large zip file
git-svn-id: file:///srv/repos/svn-community/svn@622223 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--glslang-remove-setAllocator.patch24
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7be0862b9e5d..bc70b5901a9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -44,6 +44,7 @@ pkgbase = electron4
source = chromium-SIOCGSTAMP.patch
source = chromium-skia-harmony.patch
source = icu65.patch
+ source = glslang-remove-setAllocator.patch
source = chromium-system-icu.patch
source = fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
source = only-disable-cfi-icall-when-use_system_libjpeg-true.patch
@@ -55,6 +56,7 @@ pkgbase = electron4
sha256sums = 7acc4dd59b70fb64f602ceda2846ccddcb46f64a18f912658d1034965f6c1276
sha256sums = feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3
sha256sums = 1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41
+ sha256sums = 06738b3f2d3579cd9b4d1ff876ba93d6b10a741b4deb4eab7fe3008cc577c893
sha256sums = c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5
sha256sums = 97b421bc60a4abdf37de2d88a51b973e9f68fb44d1eccd464adfb3d9f5d71478
sha256sums = 9cae9ded6497afd15ad72d963897425ab6c7f28941bb3c3948e7996610a0d180
diff --git a/PKGBUILD b/PKGBUILD
index 8edeba419ac1..1a2b14522b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,7 @@ source=('git+https://github.com/electron/electron.git'
'chromium-SIOCGSTAMP.patch'
'chromium-skia-harmony.patch'
'icu65.patch'
+ 'glslang-remove-setAllocator.patch'
'chromium-system-icu.patch'
'fix-cfi-icall-failure-with-use_system_libjpeg-true.patch'
'only-disable-cfi-icall-when-use_system_libjpeg-true.patch'
@@ -36,6 +37,7 @@ sha256sums=('SKIP'
'7acc4dd59b70fb64f602ceda2846ccddcb46f64a18f912658d1034965f6c1276'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
+ '06738b3f2d3579cd9b4d1ff876ba93d6b10a741b4deb4eab7fe3008cc577c893'
'c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5'
'97b421bc60a4abdf37de2d88a51b973e9f68fb44d1eccd464adfb3d9f5d71478'
'9cae9ded6497afd15ad72d963897425ab6c7f28941bb3c3948e7996610a0d180')
@@ -135,6 +137,8 @@ prepare() {
patch -Np1 -i ../chromium-SIOCGSTAMP.patch
patch -Np4 -i ../chromium-skia-harmony.patch
patch -Np1 -i ../icu65.patch
+ patch -Np1 -d third_party/glslang/src <../glslang-remove-setAllocator.patch
+ patch -Np1 -d third_party/angle/third_party/glslang/src <../glslang-remove-setAllocator.patch
patch -Np1 -i ../chromium-system-icu.patch
patch -Np1 -i ../fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
patch -Np1 -i ../only-disable-cfi-icall-when-use_system_libjpeg-true.patch
@@ -166,6 +170,10 @@ build() {
'
gn-m76 gen out/Release \
--args="import(\"//electron/build/args/release.gn\") ${GN_EXTRA_ARGS}"
+ ninja -C out/Release electron
+ # Strip before zip to avoid
+ # zipfile.LargeZipFile: Filesize would require ZIP64 extensions
+ strip -s out/Release/electron
ninja -C out/Release electron_dist_zip
# ninja -C out/Release third_party/electron_node:headers
}
diff --git a/glslang-remove-setAllocator.patch b/glslang-remove-setAllocator.patch
new file mode 100644
index 000000000000..3931acef437a
--- /dev/null
+++ b/glslang-remove-setAllocator.patch
@@ -0,0 +1,24 @@
+From 24b3e8384e93f3e73b6aa14ea00a30574112f9ba Mon Sep 17 00:00:00 2001
+From: Reid Kleckner <rnk@google.com>
+Date: Wed, 4 Dec 2019 14:09:03 -0800
+Subject: [PATCH] Remove glslang::pool_allocator::setAllocator
+
+TPoolAllocator is not copy assignable, so this setter could never have
+been used. After a recent change (878a24ee2), new versions of Clang
+reject this code outright.
+---
+ glslang/Include/PoolAlloc.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/glslang/Include/PoolAlloc.h b/glslang/Include/PoolAlloc.h
+index 0e237a6a2..b8eccb883 100644
+--- a/glslang/Include/PoolAlloc.h
++++ b/glslang/Include/PoolAlloc.h
+@@ -304,7 +304,6 @@ class pool_allocator {
+ size_type max_size() const { return static_cast<size_type>(-1) / sizeof(T); }
+ size_type max_size(int size) const { return static_cast<size_type>(-1) / size; }
+
+- void setAllocator(TPoolAllocator* a) { allocator = *a; }
+ TPoolAllocator& getAllocator() const { return allocator; }
+
+ protected: