summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoutrelis2019-11-12 10:39:26 +0000
committerMartin Kröning2020-06-12 10:10:19 +0200
commit1f12de4fb18af15e839fe2988e0f9e645e9639c7 (patch)
tree7cd567973f389495e702d68d762d47cd95ac34ae
parent201230b67ed7710575447756aacdfb425110d0c4 (diff)
downloadaur-1f12de4fb18af15e839fe2988e0f9e645e9639c7.tar.gz
Fix build with ICU 65
git-svn-id: file:///srv/repos/svn-community/svn@526979 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--icu65.patch64
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 312442e60388..616f1acf27ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -43,6 +43,7 @@ pkgbase = electron4
source = use-system-libraries-in-node.patch
source = chromium-SIOCGSTAMP.patch
source = chromium-skia-harmony.patch
+ source = icu65.patch
source = chromium-system-icu.patch
source = fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
source = only-disable-cfi-icall-when-use_system_libjpeg-true.patch
@@ -53,6 +54,7 @@ pkgbase = electron4
sha256sums = 3a81953701ac976a311db4e17999e67ab7c6de97ff63388f287d6497ef9adb9b
sha256sums = 7acc4dd59b70fb64f602ceda2846ccddcb46f64a18f912658d1034965f6c1276
sha256sums = feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3
+ sha256sums = 1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41
sha256sums = c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5
sha256sums = 97b421bc60a4abdf37de2d88a51b973e9f68fb44d1eccd464adfb3d9f5d71478
sha256sums = 9cae9ded6497afd15ad72d963897425ab6c7f28941bb3c3948e7996610a0d180
diff --git a/PKGBUILD b/PKGBUILD
index 3c952b10dcdf..bc3d6fc8a217 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,6 +23,7 @@ source=('git+https://github.com/electron/electron.git'
'use-system-libraries-in-node.patch'
'chromium-SIOCGSTAMP.patch'
'chromium-skia-harmony.patch'
+ 'icu65.patch'
'chromium-system-icu.patch'
'fix-cfi-icall-failure-with-use_system_libjpeg-true.patch'
'only-disable-cfi-icall-when-use_system_libjpeg-true.patch'
@@ -34,6 +35,7 @@ sha256sums=('SKIP'
'3a81953701ac976a311db4e17999e67ab7c6de97ff63388f287d6497ef9adb9b'
'7acc4dd59b70fb64f602ceda2846ccddcb46f64a18f912658d1034965f6c1276'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
+ '1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
'c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5'
'97b421bc60a4abdf37de2d88a51b973e9f68fb44d1eccd464adfb3d9f5d71478'
'9cae9ded6497afd15ad72d963897425ab6c7f28941bb3c3948e7996610a0d180')
@@ -132,6 +134,7 @@ prepare() {
echo "Applying local patches..."
patch -Np1 -i ../chromium-SIOCGSTAMP.patch
patch -Np4 -i ../chromium-skia-harmony.patch
+ patch -Np1 -i ../icu65.patch
patch -Np1 -i ../chromium-system-icu.patch
patch -Np1 -i ../fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
patch -Np1 -i ../only-disable-cfi-icall-when-use_system_libjpeg-true.patch
diff --git a/icu65.patch b/icu65.patch
new file mode 100644
index 000000000000..811d56286a98
--- /dev/null
+++ b/icu65.patch
@@ -0,0 +1,64 @@
+From 5679c3c191ed62b62d8db22f1657a296ee9bfe8e Mon Sep 17 00:00:00 2001
+From: Frank Tang <ftang@chromium.org>
+Date: Wed, 30 Oct 2019 22:49:47 +0000
+Subject: [PATCH] Update ICU to 65.1 from 64 and fix broken tests
+
+ICU 65-1 release note
+http://site.icu-project.org/download/65
+
+CLDR 36 release blog
+http://blog.unicode.org/2019/10/unicode-cldr-version-36-languagelocale.html
+
+Most of the test expectation change is due to CLDR 36 update
+of Grapheme Cluster for Indic languages
+See the following for related changes in ICU 65.1 in this area:
+https://unicode-org.atlassian.net/browse/CLDR-10994
+https://unicode-org.atlassian.net/browse/ICU-13637
+https://github.com/unicode-org/cldr/blob/master/common/properties/segments/readme.txt
+
+Bug: chromium:1014272, chromium:1017047
+Change-Id: I9fc6d4620bf2a4c189940d06d8c79893502db3dd
+Cq-Include-Trybots: luci.chromium.try:linux_layout_tests_layout_ng_disabled
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1866059
+Reviewed-by: Jungshik Shin <jshin@chromium.org>
+Reviewed-by: Doug Turner <dougt@chromium.org>
+Reviewed-by: Michael Wasserman <msw@chromium.org>
+Reviewed-by: Kent Tamura <tkent@chromium.org>
+Reviewed-by: Trent Apted <tapted@chromium.org>
+Reviewed-by: Mason Freed <masonfreed@chromium.org>
+Commit-Queue: Frank Tang <ftang@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#711027}
+---
+ third_party/blink/renderer/core/dom/document.cc | 2 +-
+ ui/gfx/render_text_harfbuzz.cc | 5 ++++-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/third_party/blink/renderer/core/dom/document.cc b/third_party/blink/renderer/core/dom/document.cc
+index 511aac29086..f188cf548a6 100644
+--- a/third_party/blink/renderer/core/dom/document.cc
++++ b/third_party/blink/renderer/core/dom/document.cc
+@@ -6191,7 +6191,7 @@ static ParseQualifiedNameResult ParseQualifiedNameInternal(
+
+ for (unsigned i = 0; i < length;) {
+ UChar32 c;
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (c == ':') {
+ if (saw_colon)
+ return ParseQualifiedNameResult(kQNMultipleColons);
+diff --git a/ui/gfx/render_text_harfbuzz.cc b/ui/gfx/render_text_harfbuzz.cc
+index 50e86af6b97..0339ff3ff8e 100644
+--- a/ui/gfx/render_text_harfbuzz.cc
++++ b/ui/gfx/render_text_harfbuzz.cc
+@@ -971,7 +971,10 @@ RangeF TextRunHarfBuzz::GetGraphemeBounds(RenderTextHarfBuzz* render_text,
+ ++total;
+ }
+ }
+- DCHECK_GT(total, 0);
++ // With ICU 65.1, DCHECK_GT() below fails.
++ // See https://crbug.com/1017047 for more details.
++ //
++ // DCHECK_GT(total, 0);
+
+ // It's possible for |text_index| to point to a diacritical mark, at the end
+ // of |chars|. In this case all the grapheme boundaries come before it. Just