summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:01:57 +0100
committerDaniel Peukert2024-01-28 00:01:57 +0100
commit7b32501fd1502941c66148a0cbc9a7279891fdfe (patch)
treefbbb5ae254b4a8bbd611315262553d489f1ed2e7
parent646b02ab331f954a08b54da29e490e9a5c348011 (diff)
downloadaur-7b32501fd1502941c66148a0cbc9a7279891fdfe.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
2 files changed, 16 insertions, 17 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 9387bff16979..e99722c7ad48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,7 +68,6 @@ package() {
install -Dm755 'electron-launcher.sh' "$pkgdir/usr/bin/$_pkgname"
- for _license in 'LICENSE' 'LICENSES.chromium.html'; do
- install -Dm644 "$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
- done
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/MIT"
+ install -Dm644 'LICENSES.chromium.html' "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
}