summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimdiels2018-03-03 13:40:46 +0100
committertimdiels2018-03-03 13:40:46 +0100
commit4025127adf62775af32143788a41b2a7e97a5742 (patch)
treea8369417577a7ea45ddd9bd875af75683a8d6a8d
parent5c1cc0875c08026dde2c92d55d2074bb8c8c1d1b (diff)
downloadaur-4025127adf62775af32143788a41b2a7e97a5742.tar.gz
v0.11.0.0-revert
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c9e2dd3134..d2e505b2dbe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electroneum
pkgdesc = Secure, private, mobile based cryptocurrency
- pkgver = 0.11.1.0
- pkgrel = 1
+ pkgver = 0.11.0.0.revert
+ pkgrel = 2
url = https://electroneum.com
arch = any
license = custom
@@ -15,8 +15,8 @@ pkgbase = electroneum
optdepends = expat: XML parsing
optdepends = doxygen: documentation
optdepends = graphviz: documentation
- source = https://github.com/electroneum/electroneum/archive/v0.11.1.0.tar.gz
- md5sums = 368005dbbd07fa8b0a90f8b9efda4ff2
+ source = https://github.com/electroneum/electroneum/archive/v0.11.0.0-revert.tar.gz
+ md5sums = ecaa9b3aaa47db4b45c1d6ab4b3274b9
pkgname = electroneum
diff --git a/PKGBUILD b/PKGBUILD
index e2082f0fbbe6..67c71a7669e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Tim Diels <timdiels.m@gmail.com>
pkgname=electroneum
-pkgver=0.11.1.0
-pkgrel=1
+pkgver=0.11.0.0.revert
+real_pkgver=0.11.0.0-revert
+pkgrel=2
pkgdesc='Secure, private, mobile based cryptocurrency '
arch=('any')
url='https://electroneum.com'
license=('custom')
makedepends=('cmake')
depends=('boost' 'openssl' 'unbound')
-#checkdepends=('gtest')
optdepends=(
'miniupnpc: NAT punching'
'libunwind: stack traces'
@@ -18,24 +18,18 @@ optdepends=(
'doxygen: documentation'
'graphviz: documentation'
)
-source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('368005dbbd07fa8b0a90f8b9efda4ff2')
+source=("https://github.com/$pkgname/$pkgname/archive/v$real_pkgver.tar.gz")
+md5sums=('ecaa9b3aaa47db4b45c1d6ab4b3274b9')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$real_pkgver"
# Note: plain make fails with undeclared DIFFICULTY_TARGET_V1
# make release-static fails when compiling with e.g. -j8
make -j1 release-static
}
-# Tests always fail due to DIFFICULT_TARGET_V1 error, so we don't run them
-#check() {
-# cd "$pkgname-$pkgver"
-# #make release-test
-#}
-
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$real_pkgver"
# Note: make has no install target. Static build means we don't need to
# install lib.
install -dm755 "$pkgdir/usr/bin/"