summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgsc2016-09-27 23:34:04 +0800
committergsc2016-09-27 23:34:04 +0800
commit0a12509df4847a1d970429a065be93748c10e385 (patch)
tree8326bc64e18c98c179369a9a41575c8dc4761068
downloadaur-0a12509df4847a1d970429a065be93748c10e385.tar.gz
add
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
-rw-r--r--electronic-wechat.desktop9
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66a8c6b94975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Sep 27 15:33:15 UTC 2016
+pkgbase = electronic-wechat-bin
+ pkgdesc = A better WeChat on macOS and Linux. Built with Electron by Zhongyi Tong.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/geeeeeeeeek/electronic-wechat
+ arch = i686
+ arch = x86_64
+ license = MIT
+ conflicts = electronic-wechat
+ conflicts = electronic-wechat-git
+ replaces = electronic-wechat
+ replaces = electronic-wechat-git
+ source = https://github.com/geeeeeeeeek/electronic-wechat/releases/download/v1.4.0/linux-x64.tar.gz
+ source = https://github.com/geeeeeeeeek/electronic-wechat/raw/master/assets/icon.png
+ source = electronic-wechat.desktop
+ md5sums = d0414988530314491edcc81162295131
+ md5sums = 5067d2ecdfa58d16affc950102cd36bd
+ md5sums = ffc9bdbcce89519b59f78d4bb50ea315
+
+pkgname = electronic-wechat-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2bf5d28fa34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+#Maintainer:xgdgsc<xgdgsc@gmail.com>
+
+pkgname=electronic-wechat-bin
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A better WeChat on macOS and Linux. Built with Electron by Zhongyi Tong."
+url=https://github.com/geeeeeeeeek/electronic-wechat
+arch=(i686 x86_64)
+replaces=('electronic-wechat' 'electronic-wechat-git')
+conflicts=('electronic-wechat' 'electronic-wechat-git')
+depends=()
+license=(MIT)
+
+
+md5sums=('d0414988530314491edcc81162295131'
+'5067d2ecdfa58d16affc950102cd36bd'
+'ffc9bdbcce89519b59f78d4bb50ea315')
+
+if [[ $CARCH = i686 ]];then
+ md5sums[0]='8556d6228b4bad238c63003e44c626cf'
+ _arch=ia32
+else
+ _arch=x64
+fi
+source=("https://github.com/geeeeeeeeek/electronic-wechat/releases/download/v$pkgver/linux-$_arch.tar.gz"
+"https://github.com/geeeeeeeeek/electronic-wechat/raw/master/assets/icon.png"
+"electronic-wechat.desktop")
+
+
+package() {
+ mkdir -p "${pkgdir}/opt/$pkgname"
+ cp icon.png "${pkgdir}/opt/$pkgname/"
+
+ install -dm755 "$pkgdir"/usr/share/applications
+ cp electronic-wechat.desktop "$pkgdir"/usr/share/applications
+
+ cd electronic-wechat-linux-$_arch
+ install -dm755 "$pkgdir/opt/$pkgname/"
+ mv * "$pkgdir/opt/$pkgname/"
+
+ install -dm755 "$pkgdir"/usr/bin
+ ln -s /opt/"$pkgname"/electronic-wechat "$pkgdir/usr/bin/electronic-wechat"
+
+}
diff --git a/electronic-wechat.desktop b/electronic-wechat.desktop
new file mode 100644
index 000000000000..473890aace7d
--- /dev/null
+++ b/electronic-wechat.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Electronic WeChat
+Comment=A better WeChat client
+Exec=/usr/bin/electronic-wechat
+Icon=/opt/electronic-wechat-bin/icon.png
+Categories=Network;InstantMessaging;Application;
+Terminal=false
+StartupNotify=true