summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-02-27 14:07:19 +0800
committerwenLiangcan2016-02-27 14:07:19 +0800
commit148fb86b211a8698c422dc3a20f9d055f889d79d (patch)
tree887caded7c1318cbe4941c29b0efd911d25755fb
parent9c2452ca4e4345116406726b2cb84961a2f1b563 (diff)
downloadaur-148fb86b211a8698c422dc3a20f9d055f889d79d.tar.gz
electronic-wechat-git 0.1.38.g22802f2-2.
Make the app icon be able to displayed on titlebar.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 017b058ec49b..c7ac74733a05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 27 03:33:11 UTC 2016
+# Sat Feb 27 06:07:01 UTC 2016
pkgbase = electronic-wechat-git
pkgdesc = An Electron application for WeChat
pkgver = 0.1.38.g22802f2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/geeeeeeeeek/wechat-electron/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 25e68c297ac0..3c7277479eb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _npmver=0.1.0
pkgname=electronic-wechat-git
_pkgname=electronic-wechat
pkgver=0.1.38.g22802f2
-pkgrel=1
+pkgrel=2
pkgdesc="An Electron application for WeChat"
arch=('any')
url="https://github.com/geeeeeeeeek/wechat-electron/"
@@ -21,14 +21,14 @@ pkgver() {
git describe --tags | sed 's/^v//;s/-/./g'
}
-build() {
+prepare() {
cat > ${_desktop} << EOF
[Desktop Entry]
Type=Application
Name=Electronic WeChat
Comment=A better WeChat client on Mac OS X and Linux.
Exec=/usr/bin/${_pkgname}
-Icon=/usr/share/${_pkgname}/assets/icon.png
+Icon=/usr/share/${_pkgname}/icon.png
Categories=Network;InstantMessaging;Application;
Terminal=false
StartupNotify=true
@@ -37,15 +37,16 @@ EOF
cat > "${_pkgname}.sh" << EOF
#!/usr/bin/env sh
-electron /usr/share/${_pkgname}/src/main.js \$*
+cd /usr/share/${_pkgname}/
+electron ./ \$*
EOF
-
}
package() {
cd "${_pkgname}"
- find ./{src,assets} -type f -exec install -Dm644 {} \
+ find ./src -type f -exec install -Dm644 {} \
"${pkgdir}/usr/share/${_pkgname}/{}" \;
+ install -Dm644 ./{assets/icon.png,package.json} "${pkgdir}/usr/share/${_pkgname}/"
install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
install -Dm644 "${srcdir}/${_desktop}" "${pkgdir}/usr/share/applications/${_desktop}"
install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"