summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-02-25 21:37:44 +0800
committerwenLiangcan2016-02-25 21:37:44 +0800
commit69ae4c785b32a0f655352b94d7dbd9208086e345 (patch)
treee0d1322cd4e6a5cee654004a791bf70e7e881944
downloadaur-69ae4c785b32a0f655352b94d7dbd9208086e345.tar.gz
electronic-wechat-git 0.1.18.ge77c778-1.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD54
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08ffa73382bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Feb 25 13:35:39 UTC 2016
+pkgbase = electronic-wechat-git
+ pkgdesc = An Electron application for WeChat
+ pkgver = 0.1.18.ge77c778
+ pkgrel = 1
+ url = https://github.com/geeeeeeeeek/wechat-electron/
+ arch = any
+ license = MIT
+ depends = electron
+ depends = xdg-utils
+ provides = electronic-wechat
+ conflicts = electronic-wechat
+ source = git+https://github.com/geeeeeeeeek/electronic-wechat.git
+ sha1sums = SKIP
+
+pkgname = electronic-wechat-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1ff8c50e7353
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+### https://raw.github.com/github/gitignore/fa441f903154d8159ef71db23d4816d802450fef/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+electronic-wechat
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..345be468e83c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+_npmver=0.1.0
+pkgname=electronic-wechat-git
+_pkgname=electronic-wechat
+pkgver=0.1.18.ge77c778
+pkgrel=1
+pkgdesc="An Electron application for WeChat"
+arch=('any')
+url="https://github.com/geeeeeeeeek/wechat-electron/"
+license=('MIT')
+depends=('electron' 'xdg-utils')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=('git+https://github.com/geeeeeeeeek/electronic-wechat.git')
+sha1sums=('SKIP')
+_desktop="${_pkgname}.desktop"
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ cat > ${_desktop} << EOF
+[Desktop Entry]
+Type=Application
+Name=Electronic WeChat
+Comment=A better WeChat client on Mac OS X and Linux.
+Exec=/usr/bin/${_pkgname}
+Icon=/usr/share/${_pkgname}/assets/icon.png
+Type=Application
+Categories=Network;InstantMessaging;Application;
+Terminal=false
+StartupNotify=true
+Version=${pkgver}
+EOF
+
+ cat > "${_pkgname}.sh" << EOF
+#!/usr/bin/env sh
+electron /usr/share/${_pkgname}/src/main.js \$*
+EOF
+
+}
+
+package() {
+ cd "${_pkgname}"
+ find ./{src,assets} -type f -exec install -Dm644 {} \
+ "${pkgdir}/usr/share/${_pkgname}/{}" \;
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${_desktop}" "${pkgdir}/usr/share/applications/${_desktop}"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+}
+