summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock2022-12-25 10:40:42 +0800
committerKimiblock2022-12-25 10:40:42 +0800
commit21e4d9106f981c5ca918c7be3d4db23f46db40a4 (patch)
tree3a04c9ccff4858a3e96bd4ad5ec1f7e8b911e0b7
parent0bcf6cba40a194200d77ed453b593698d573b6cc (diff)
downloadaur-21e4d9106f981c5ca918c7be3d4db23f46db40a4.tar.gz
修复了 Pamac 无法构建的问题
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xelectronic-wechat-uos-bin.install15
2 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c05f8086481..cb53cd7a7bad 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,9 +55,13 @@ exec electron /opt/electronic-wechat-uos-bin/resources/app.asar' >${pkgdir}/usr/
}
function info() {
+ if [ -f /usr/bin/pamac ]; then
+ echo " ==> [Info]: $@"
+ else
all_off="$(tput sgr0)"
bold="${all_off}$(tput bold)"
blue="${bold}$(tput setaf 4)"
yellow="${bold}$(tput setaf 3)"
printf "${blue}==>${yellow} [Info]:${bold} $1${all_off}\n"
+ fi
}
diff --git a/electronic-wechat-uos-bin.install b/electronic-wechat-uos-bin.install
index b0dd488d6642..cea6de07acfb 100755
--- a/electronic-wechat-uos-bin.install
+++ b/electronic-wechat-uos-bin.install
@@ -1,12 +1,15 @@
function note() {
- printf "${blue}==>${yellow} 提示:${bold} $1${all_off}\n"
+ if [ -f /usr/bin/pamac ]; then
+ echo " ==> [Info]: $@"
+ else
+ all_off="$(tput sgr0)"
+ bold="${all_off}$(tput bold)"
+ blue="${bold}$(tput setaf 4)"
+ yellow="${bold}$(tput setaf 3)"
+ printf "${blue}==>${yellow} [Info]:${bold} $1${all_off}\n"
+ fi
}
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-blue="${bold}$(tput setaf 4)"
-yellow="${bold}$(tput setaf 3)"
-
function post_install(){
note '如果桌面通知无法送达, 请检查是否正确设置 libnotify'
note '若要启用 Wayland 支持, 请在 ~/.config/electron-flags.conf 添加 --enable-features=WaylandWindowDecorations 与 --ozone-platform-hint=auto'