summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock Moe2024-01-11 07:44:41 +0800
committerKimiblock Moe2024-01-11 07:44:41 +0800
commitb9f82f737f021eab8208075eb61f7f6fcc3a0cfb (patch)
tree82eafaec17c755f7caea95d27a7c1343bba88e83
parent27279c27adede0fe5cdd4c81b04ff8cf5d53604b (diff)
downloadaur-b9f82f737f021eab8208075eb61f7f6fcc3a0cfb.tar.gz
feat: better portal dependency handling
-rwxr-xr-xPKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f47922a55bad..fecc1d8174cd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,4 +55,9 @@ VERSION_CODENAME=eagle''' >"${pkgdir}/usr/lib/electronic-wechat-uos-bin/os-relea
DISTRIB_RELEASE=20
DISTRIB_DESCRIPTION="UnionTech OS 20"
DISTRIB_CODENAME=plum''' >"${pkgdir}/usr/lib/electronic-wechat-uos-bin/lsb-release"
+ if [[ ${XDG_CURRENT_DESKTOP} =~ GNOME ]]; then
+ depends+=(xdg-desktop-portal-gnome)
+ elif [[ ${XDG_CURRENT_DESKTOP} =~ KDE ]]; then
+ depends+=(xdg-desktop-portal-kde)
+ fi
}